summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-05 18:25:43 -0300
committerPacho Ramos <pacho@gentoo.org>2025-01-25 17:48:28 +0100
commit6b4b8d27ef2b63a75272d9268c8db4940aa6cfea (patch)
tree6343642ae9729ba6b913f63a7d10eb23291dffe8 /gnome-extra
parentgnome-extra/evolution-data-server: Bump to 3.54.3 (diff)
downloadgentoo-6b4b8d27ef2b63a75272d9268c8db4940aa6cfea.tar.gz
gentoo-6b4b8d27ef2b63a75272d9268c8db4940aa6cfea.tar.bz2
gentoo-6b4b8d27ef2b63a75272d9268c8db4940aa6cfea.zip
gnome-extra/evolution-ews: Bump to 3.54.3.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38608 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.54.3.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 199ed6c77bd5..f135db9374f1 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.50.2.tar.xz 707800 BLAKE2B 18241eff067658af2f4620af87dea1c9c7c62476bbf9bf259addf15868a3b7e3f156dc952f21af2cad7ba6c2da9fd348b8733e5887f4276ad7eeeca8f9088476 SHA512 9aa4bb023922e39132a0ac3171d95f8362116960aa14dcb961b31ad242e6d7bcf2e946f19aea2c6f9a5324ca0954731264594a27fbb2b0e2cc38eca0cf441108
DIST evolution-ews-3.52.4.tar.xz 724244 BLAKE2B 35b78fa600e06c18cecee8c43941e77b3645a7d4487d72d989da62a0c7acab83f2adf4363c761d7e313f42175f341d63ec7709003599bf5b37e80424cc76d67c SHA512 017dbe28ba6524cdad1582cebd00fb675c75f52cac5875c756be0f402d4a0dd4a83e60b7ee0a2f71211eac49c04bba924e3d71775dce1e55fdcd372b1ac3747d
+DIST evolution-ews-3.54.3.0.tar.xz 737492 BLAKE2B bf78efdc60953c7723eaf952456b97b42d9189437d1d6fe535c3d73724df5d89856f144474890359154058080616cf610cb3b58f170a6c4b247c6fb0907af122 SHA512 f914daab6d5765c18c8f58583a97ce41aacf8a7ebe43c250d3ce764062846beae03e4bdc1f11ea7f0182a74ac7b976f74c88043b8a8a323af8866aa6e0bf0515
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.54.3.0.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.54.3.0.ebuild
new file mode 100644
index 000000000000..de2ed447ae57
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.54.3.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/evolution/-/wikis/home https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[glib]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-3.54.3:0=
+ >=mail-client/evolution-3.54.3:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" "gnome-extra/evolution-data-server[oauth-gtk3]"
+}