summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-30 12:18:23 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-30 13:50:53 +0200
commit5bdc866c6fd38850f8feb9561054e523b607dd6f (patch)
treee474af841476533fa51426968c2a2632cca15177 /games-util
parentdev-vcs/git: x86 stable wrt bug #836296 (diff)
downloadgentoo-5bdc866c6fd38850f8feb9561054e523b607dd6f.tar.gz
gentoo-5bdc866c6fd38850f8feb9561054e523b607dd6f.tar.bz2
gentoo-5bdc866c6fd38850f8feb9561054e523b607dd6f.zip
games-util/lutris: add 0.5.10_beta2
Bug: https://github.com/lutris/lutris/issues/4175 Bug: https://bugs.gentoo.org/835897 Bug: https://bugs.gentoo.org/822969 Bug: https://bugs.gentoo.org/836332 Bug: https://bugs.gentoo.org/820860 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24815 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/files/lutris-0.5.10_beta2-fix-install-requires.patch13
-rw-r--r--games-util/lutris/files/lutris-0.5.10_beta2-fix-launching-steam.patch22
-rw-r--r--games-util/lutris/lutris-0.5.10_beta2.ebuild88
4 files changed, 124 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 61166b09c69a..c2c55885295b 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1 +1,2 @@
+DIST lutris-0.5.10_beta2.tar.gz 1006201 BLAKE2B 39a87735408639070ef21182adf23ae816a14aeb0d6acf6e36f67bc213ca21559374cc02f0ca696b65eda20b76f33240a7f15d74bca6c3852641d0827737e96c SHA512 0dd0896be70c8902aa09b8bb0e45e516c8631f82a5451e15b3eaf932a5881bccd1189b5564c4cc544fb4eb1ec902cbae887618f5edda0e13d23a19dd0b71dba7
DIST lutris_0.5.9.1.tar.xz 1046920 BLAKE2B 469e7707e74d957be3bb0f5f1caeaeaaf7c01dc3b998c16d8be4b4b780e408763bbe0df5c0b5f6a53ebcb3eb478aaaf25f9cf16437ae682dfcd1d2213222fa18 SHA512 a94e37d1a3f5b80353af38900f3e67763af9c0e3cc3013f7998e23ff70cb6f329730b1802f996866dac541af6e50388a5308c772e3a2ee97f87e5ae60878e7e7
diff --git a/games-util/lutris/files/lutris-0.5.10_beta2-fix-install-requires.patch b/games-util/lutris/files/lutris-0.5.10_beta2-fix-install-requires.patch
new file mode 100644
index 000000000000..8a61d987cece
--- /dev/null
+++ b/games-util/lutris/files/lutris-0.5.10_beta2-fix-install-requires.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 0388119..51bc8e1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -57,7 +57,7 @@ setup(
+ 'evdev',
+ 'requests',
+ 'python-magic',
+- "distro>=1.7.0;platform_system='Linux'",
++ 'distro>=1.7.0',
+ 'lxml'
+ ],
+ url='https://lutris.net',
diff --git a/games-util/lutris/files/lutris-0.5.10_beta2-fix-launching-steam.patch b/games-util/lutris/files/lutris-0.5.10_beta2-fix-launching-steam.patch
new file mode 100644
index 000000000000..2edd6569ce75
--- /dev/null
+++ b/games-util/lutris/files/lutris-0.5.10_beta2-fix-launching-steam.patch
@@ -0,0 +1,22 @@
+From 072e72a4aefd91101b79dd05d8ce9f100a4b6b0c Mon Sep 17 00:00:00 2001
+From: Mathieu Comandon <strycore@gmail.com>
+Date: Fri, 25 Feb 2022 14:02:12 -0800
+Subject: [PATCH] contentstatsid key might not be present
+
+---
+ lutris/util/steam/config.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lutris/util/steam/config.py b/lutris/util/steam/config.py
+index 237cb36f24..bae2ec22da 100644
+--- a/lutris/util/steam/config.py
++++ b/lutris/util/steam/config.py
+@@ -158,7 +158,7 @@ def get_entry_case_insensitive(library_dict, path):
+ with open(library_filename, "r", encoding='utf-8') as steam_library_file:
+ library = vdf_parse(steam_library_file, {})
+ # The contentstatsid key is unused and causes problems when looking for library paths.
+- library["libraryfolders"].pop("contentstatsid")
++ library["libraryfolders"].pop("contentstatsid", None)
+ try:
+ return get_entry_case_insensitive(library, ["libraryfolders"])
+ except KeyError as ex:
diff --git a/games-util/lutris/lutris-0.5.10_beta2.ebuild b/games-util/lutris/lutris-0.5.10_beta2.ebuild
new file mode 100644
index 000000000000..0f6bb9cf095a
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.10_beta2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+
+ KEYWORDS="~amd64 ~x86"
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/libnotify[introspection]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.9.1-avoid-gtk-4.0-already-loaded-testerror.patch"
+ "${FILESDIR}/${P}-fix-install-requires.patch"
+ "${FILESDIR}/${P}-fix-launching-steam.patch"
+)
+
+python_test() {
+ virtx epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}