summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2020-09-20 13:17:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-28 14:32:59 +0300
commite2df147d5abdb9bad470fbb41255b96b0d63d8d1 (patch)
tree4905e02010251f48921dd61f5aa891ff717d02bd /games-util/gamemode
parentgames-util/gamemode: Bump to 1.6 (diff)
downloadgentoo-e2df147d5abdb9bad470fbb41255b96b0d63d8d1.tar.gz
gentoo-e2df147d5abdb9bad470fbb41255b96b0d63d8d1.tar.bz2
gentoo-e2df147d5abdb9bad470fbb41255b96b0d63d8d1.zip
games-util/gamemode: Drop old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kai Krakow <kai@kaishome.de> Closes: https://github.com/gentoo/gentoo/pull/13158 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util/gamemode')
-rw-r--r--games-util/gamemode/Manifest1
-rw-r--r--games-util/gamemode/gamemode-1.2.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
index f355f07bddd7..9993c2e7000d 100644
--- a/games-util/gamemode/Manifest
+++ b/games-util/gamemode/Manifest
@@ -1,2 +1 @@
-DIST gamemode-1.2.tar.xz 38536 BLAKE2B af39b8c0585c522afa72238b8332a6a5301d36b3c53e50652a78c41788eae9f5cb319cad06eaf6f345c50f934e188df4c78d70efbad919dd6897d3350d14e568 SHA512 233602e5e93b6cfcc742510dafb00dc826000d0c8618a693e9a579dc3b31c546d22c0545084cfb78c6085226e6b0e26c066078bc1871d36d5fb90828cf63cea9
DIST gamemode-1.6.tar.xz 69916 BLAKE2B 2fbb680de4043a004a91005647208fd9ca25de250bffe97acc0cabea47dba90d1ef670478582203d616704ea1f5a771115aadef4971e1e41f078104116b08cc4 SHA512 7cb4f4dd51b35e3a0164092342be56ce70bf1a81a8ff071725b429378cf92a100e263bc33890d5f5e281ad87fb72e2f820cb716c5aedf14f387610dcb59eb690
diff --git a/games-util/gamemode/gamemode-1.2.ebuild b/games-util/gamemode/gamemode-1.2.ebuild
deleted file mode 100644
index 45b778ba90e2..000000000000
--- a/games-util/gamemode/gamemode-1.2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-inherit meson multilib-minimal ninja-utils user
-
-DESCRIPTION="Optimise Linux system performance on demand"
-HOMEPAGE="https://github.com/FeralInteractive/gamemode"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
- GAMEMODE_GIT_PTR="master"
- inherit git-r3
-else
- GAMEMODE_GIT_PTR="${PV}"
- SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
- sys-auth/polkit
-"
-DEPEND="${RDEPEND}"
-
-pkg_pretend() {
- elog
- elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
- elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
- elog "and sys-kernel/pf-sources."
- elog
- elog "Support for soft realtime is completely optional. It may provide the"
- elog "following benefits with systems having at least four CPU cores:"
- elog
- elog " * more CPU shares allocated exclusively to the game"
- elog " * reduced input lag and reduced thread latency"
- elog " * more consistent frame times resulting in less microstutters"
- elog
- elog "You probably won't benefit from soft realtime mode and thus don't need"
- elog "SCHED_ISO if:"
- elog
- elog " * Your CPU has less than four cores because the game may experience"
- elog " priority inversion with the graphics driver (thus heuristics"
- elog " automatically disable SCHED_ISO usage then)"
- elog " * Your game uses busy-loops to interface with the graphics driver"
- elog " but you may still force SCHED_ISO per configuation file, YMMV,"
- elog " it depends on the graphics driver implementation, i.e. usage of"
- elog " __GL_THREADED_OPTIMIZATIONS or similar."
- elog " * If your game causes more than 70% CPU usage across all cores,"
- elog " SCHED_ISO automatically turns off and on depending on usage and"
- elog " is processed with higher-than-normal priority then (renice)."
- elog " This auto-switching may result in a lesser game experience."
- elog
- elog "For more info look at:"
- elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
- elog
-}
-
-multilib_src_configure() {
- local myconf=()
- if ! multilib_is_native_abi; then
- myconf+=(
- -Dwith-examples=false
- -Dwith-daemon=false
- )
- fi
- meson_src_configure "${myconf[@]}"
-}
-
-multilib_src_compile() {
- eninja
-}
-
-multilib_src_install() {
- DESTDIR="${D}" eninja install
- if multilib_is_native_abi; then
- insinto /etc/security/limits.d
- newins - 45-gamemode.conf <<-EOF
- @gamemode - nice -10
- EOF
- fi
-}
-
-pkg_postinst() {
- enewgroup gamemode
-
- elog
- elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
- elog "Run the following command as root to add your user:"
- elog "# gpasswd -a USER gamemode # with USER = your user name"
- elog
-
- elog "Enable and start the daemon in your systemd user instance, then add"
- elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
- elog "to the start options of any steam game to enable the performance"
- elog "governor as you start the game."
- elog
-}