summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/fteqcc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/fteqcc')
-rw-r--r--games-util/fteqcc/Manifest1
-rw-r--r--games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch93
-rw-r--r--games-util/fteqcc/fteqcc-2501.ebuild42
-rw-r--r--games-util/fteqcc/metadata.xml8
4 files changed, 144 insertions, 0 deletions
diff --git a/games-util/fteqcc/Manifest b/games-util/fteqcc/Manifest
new file mode 100644
index 000000000000..47913632f85c
--- /dev/null
+++ b/games-util/fteqcc/Manifest
@@ -0,0 +1 @@
+DIST qclibsrc2501.zip 204047 SHA256 2de9e022996a6758b31390db8133a1af8a161ea2e962a9f7a12564139848d305 SHA512 60740e55c470dcb8deb235b49b5e8bd56f3c932fd9290808224b4d0ff2d6d8eb95302fdd1c972f36c992ac046fdbbc6a34c6de2fc67e1e7de54f23fd10de89d7 WHIRLPOOL 33ff136d20a4042d25a82ba7dbdc1c9a9883d409ffdd347d64d9001c5a186ca3495cd4b49b460dedb0140a3d8250f9f68d4a41dad299685c74e167770dcb2653
diff --git a/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch b/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch
new file mode 100644
index 000000000000..35f3dcf100ae
--- /dev/null
+++ b/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch
@@ -0,0 +1,93 @@
+--- qcc_pr_comp.c
++++ qcc_pr_comp.c
+@@ -7322,7 +7322,7 @@
+ QCC_def_t *def, *d;
+ QCC_function_t *f;
+ QCC_dfunction_t *df;
+- int i;
++ int i = 0;
+ pbool shared=false;
+ pbool externfnc=false;
+ pbool isconstant = false;
+@@ -8541,8 +8545,6 @@
+ struct qcc_includechunk_s *oldcurrentchunk;
+ extern struct qcc_includechunk_s *currentchunk;
+
+- extern char qccmsourcedir[];
+-
+ ocompilingfile = compilingfile;
+ os_file = s_file;
+ os_file2 = s_file2;
+--- hash.h
++++ hash.h
+@@ -19,12 +19,12 @@
+ int Hash_Key(char *name, int modulus);
+ void *Hash_Get(hashtable_t *table, char *name);
+ void *Hash_GetInsensative(hashtable_t *table, char *name);
+-void *Hash_GetKey(hashtable_t *table, int key);
++void *Hash_GetKey(hashtable_t *table, long key);
+ void *Hash_GetNext(hashtable_t *table, char *name, void *old);
+ void *Hash_GetNextInsensative(hashtable_t *table, char *name, void *old);
+ void *Hash_Add(hashtable_t *table, char *name, void *data, bucket_t *buck);
+ void *Hash_AddInsensative(hashtable_t *table, char *name, void *data, bucket_t *buck);
+ void Hash_Remove(hashtable_t *table, char *name);
+ void Hash_RemoveData(hashtable_t *table, char *name, void *data);
+-void Hash_RemoveKey(hashtable_t *table, int key);
+-void *Hash_AddKey(hashtable_t *table, int key, void *data, bucket_t *buck);
++void Hash_RemoveKey(hashtable_t *table, long key);
++void *Hash_AddKey(hashtable_t *table, long key, void *data, bucket_t *buck);
+--- hash.c
++++ hash.c
+@@ -68,7 +68,7 @@
+ }
+ return NULL;
+ }
+-void *Hash_GetKey(hashtable_t *table, int key)
++void *Hash_GetKey(hashtable_t *table, long key)
+ {
+ int bucknum = key%table->numbuckets;
+ bucket_t *buck;
+@@ -77,7 +77,7 @@
+
+ while(buck)
+ {
+- if ((int)buck->keystring == key)
++ if ((long)buck->keystring == key)
+ return buck->data;
+
+ buck = buck->next;
+@@ -168,7 +168,7 @@
+
+ return buck;
+ }
+-void *Hash_AddKey(hashtable_t *table, int key, void *data, bucket_t *buck)
++void *Hash_AddKey(hashtable_t *table, long key, void *data, bucket_t *buck)
+ {
+ int bucknum = key%table->numbuckets;
+
+@@ -237,14 +237,14 @@
+ }
+
+
+-void Hash_RemoveKey(hashtable_t *table, int key)
++void Hash_RemoveKey(hashtable_t *table, long key)
+ {
+ int bucknum = key%table->numbuckets;
+ bucket_t *buck;
+
+ buck = table->bucket[bucknum];
+
+- if ((int)buck->keystring == key)
++ if ((long)buck->keystring == key)
+ {
+ table->bucket[bucknum] = buck->next;
+ return;
+@@ -253,7 +253,7 @@
+
+ while(buck->next)
+ {
+- if ((int)buck->next->keystring == key)
++ if ((long)buck->next->keystring == key)
+ {
+ buck->next = buck->next->next;
+ return;
diff --git a/games-util/fteqcc/fteqcc-2501.ebuild b/games-util/fteqcc/fteqcc-2501.ebuild
new file mode 100644
index 000000000000..b8f4040e6439
--- /dev/null
+++ b/games-util/fteqcc/fteqcc-2501.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="QC compiler"
+HOMEPAGE="http://fteqw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fteqw/qclibsrc${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cleanup-source.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e "s: -O3 : :g" \
+ -e "s: -s : :g" \
+ -e 's/-o fteqcc.bin/$(LDFLAGS) -o fteqcc.bin/' \
+ Makefile || die "sed failed"
+ edos2unix readme.txt
+ append-flags -DQCCONLY
+}
+
+src_compile() {
+ emake BASE_CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ newbin fteqcc.bin fteqcc
+ dodoc readme.txt
+}
diff --git a/games-util/fteqcc/metadata.xml b/games-util/fteqcc/metadata.xml
new file mode 100644
index 000000000000..89e90bd88787
--- /dev/null
+++ b/games-util/fteqcc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">fteqw</remote-id>
+ </upstream>
+</pkgmetadata>