summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/catcodec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/catcodec')
-rw-r--r--games-util/catcodec/Manifest1
-rw-r--r--games-util/catcodec/catcodec-1.0.3.ebuild30
-rw-r--r--games-util/catcodec/files/catcodec-1.0.3-gcc47.patch24
-rw-r--r--games-util/catcodec/metadata.xml5
4 files changed, 60 insertions, 0 deletions
diff --git a/games-util/catcodec/Manifest b/games-util/catcodec/Manifest
new file mode 100644
index 000000000000..944a73dd6f71
--- /dev/null
+++ b/games-util/catcodec/Manifest
@@ -0,0 +1 @@
+DIST catcodec-1.0.3-source.tar.bz2 18536 SHA256 b6a9fe31cf736b1432d84fd86ba7441159e3707c0387bb732eeb717f7d8aa9bb SHA512 406476ecc57b87355d0eca4672c8ccb067d80a0bde217a8332d1014dce983f62dd4f134d0736da806d21a375a9e053d61a79bb7ca9848f83ff2cd49fdf220360 WHIRLPOOL 3f1f8528c47f31929c68bebf6052e7a73d7a2942085ab02744e31e7560fc1b7a0498eeafabc8a01acb9edf6b7a2527af66410e2371b7e42d7a5b0313a555d3c2
diff --git a/games-util/catcodec/catcodec-1.0.3.ebuild b/games-util/catcodec/catcodec-1.0.3.ebuild
new file mode 100644
index 000000000000..48d29027650a
--- /dev/null
+++ b/games-util/catcodec/catcodec-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
+HOMEPAGE="http://www.openttd.org/en/download-catcodec"
+SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE=""
+
+src_prepare() {
+ tc-export CXX
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_compile() {
+ emake VERBOSE=1
+}
+
+src_install() {
+ dobin catcodec
+ dodoc changelog.txt docs/readme.txt
+ doman docs/catcodec.1
+}
diff --git a/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch b/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch
new file mode 100644
index 000000000000..a36546a43aab
--- /dev/null
+++ b/games-util/catcodec/files/catcodec-1.0.3-gcc47.patch
@@ -0,0 +1,24 @@
+diff -ruN src/io.cpp.orig src/io.cpp
+--- src/io.cpp.orig 2012-05-19 20:48:05.930777509 +0200
++++ src/io.cpp 2012-05-19 20:49:04.303822711 +0200
+@@ -20,6 +20,8 @@
+
+ /** @file io.cpp Implementation of reading/writing to files */
+
++#include <unistd.h>
++
+ #include "stdafx.h"
+ #include "io.hpp"
+
+diff -ruN src/catcodec.cpp.orig src/catcodec.cpp
+--- src/catcodec.cpp.orig 2012-05-19 20:47:55.847255343 +0200
++++ src/catcodec.cpp 2012-05-19 20:48:38.937144091 +0200
+@@ -22,6 +22,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #include "stdafx.h"
+ #include "io.hpp"
+
diff --git a/games-util/catcodec/metadata.xml b/games-util/catcodec/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/catcodec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>