summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-03 13:57:25 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-03 14:34:25 -0400
commita7ec6dcd8f9fea544c630cd3a4df1f6ddc8ed46e (patch)
tree208dd5d85c480f96d50e7dd7c1c844b3494b463b /games-fps
parentgames-fps/yamagi-quake2: version bump to 8.10 (diff)
downloadgentoo-a7ec6dcd8f9fea544c630cd3a4df1f6ddc8ed46e.tar.gz
gentoo-a7ec6dcd8f9fea544c630cd3a4df1f6ddc8ed46e.tar.bz2
gentoo-a7ec6dcd8f9fea544c630cd3a4df1f6ddc8ed46e.zip
games-fps/yamagi-quake2: adjust opengl/gles deps
Mesa is the vendor which could be something else (aka nvidia), and not much sense in checking directly. On the other hand, I needed to enable gles2 on libsdl2 (flag handles gles3 too) or it'd complain when I tried to use it, or at least with libsdl2[-opengl]. virtual/opengl is also mostly deprecated, so switch to libglvnd (this is not wired to use libOpenGL over libGL so still need [X]). Also add gles as a REQUIRED_USE option, I could USE="client gles -*" with libsdl2[-opengl,gles2] and run this with +set vid_renderer gles3. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/yamagi-quake2/yamagi-quake2-8.10.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/games-fps/yamagi-quake2/yamagi-quake2-8.10.ebuild b/games-fps/yamagi-quake2/yamagi-quake2-8.10.ebuild
index 3ae5a8fc5ca0..4a4a792e4187 100644
--- a/games-fps/yamagi-quake2/yamagi-quake2-8.10.ebuild
+++ b/games-fps/yamagi-quake2/yamagi-quake2-8.10.ebuild
@@ -27,17 +27,20 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="+client ctf dedicated gles openal +opengl rogue softrender vulkan xatrix"
REQUIRED_USE="
|| ( client dedicated )
- client? ( || ( opengl softrender vulkan ) )
+ client? ( || ( opengl gles softrender vulkan ) )
"
RDEPEND="
client? (
media-libs/libsdl2[opengl?,video,vulkan?]
net-misc/curl
+ gles? (
+ media-libs/libglvnd
+ media-libs/libsdl2[gles2]
+ )
openal? ( media-libs/openal )
!openal? ( media-libs/libsdl2[sound] )
- opengl? ( virtual/opengl )
- gles? ( media-libs/mesa[gles2] )
+ opengl? ( media-libs/libglvnd[X] )
)
"
DEPEND="${RDEPEND}