summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-21 16:58:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-21 17:10:01 +0200
commitb1c1432cd5c1f3a360672df77325e7edddc392e6 (patch)
tree9b539c95f52a98e93922798452ea5c8d96c79a5b /games-emulation
parentx11-drivers/nvidia-drivers: add 555.42.02 unkeyworded (beta) (diff)
downloadgentoo-b1c1432cd5c1f3a360672df77325e7edddc392e6.tar.gz
gentoo-b1c1432cd5c1f3a360672df77325e7edddc392e6.tar.bz2
gentoo-b1c1432cd5c1f3a360672df77325e7edddc392e6.zip
games-emulation/mupen64plus-video-glide64mk2: Backport boost-1.85 fix
Closes: https://bugs.gentoo.org/932249 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/Manifest1
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild26
2 files changed, 19 insertions, 8 deletions
diff --git a/games-emulation/mupen64plus-video-glide64mk2/Manifest b/games-emulation/mupen64plus-video-glide64mk2/Manifest
index 3a384ab175c6..602ddf4e193a 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/Manifest
+++ b/games-emulation/mupen64plus-video-glide64mk2/Manifest
@@ -1 +1,2 @@
+DIST mupen64plus-video-glide64mk2-2.5.9-boost-1.85.patch 11979 BLAKE2B 5c8b8c839547f5e141a2a2def5b0afc3c69aba84cc7cf65cb447ccc29f91e6e02aa7fb2d30f635f8f7e36e21e4b8cbeffac2301aceb021b09064631dd42b94bd SHA512 239120ce13343bb4d0fe8031db893b873fccebfe60926a41b2d5af94b376ba4ef79292c645d14eba50ef433e33d4fea538a46ded6ef3c2c2017c4efe83d55fa6
DIST mupen64plus-video-glide64mk2-src-2.5.9.tar.gz 498350 BLAKE2B 8378cfc9fe624b3441e290d44d600e30a85393aca5a5a5867fb778a665ea0718ae15ba67ce5b62930cd4feffb7b1ddce88be6434de9791c82a979aa8f022ecd1 SHA512 cc4cce1a1f036cdda0748cf9eb758f21ba08dbe83a2844cf92d3e781102aaa3556934ca01dbae248a2d93c65209932b858988030beaa29395d79df70bf479bd4
diff --git a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
index d0d4d129fb2a..f7f838337371 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
+++ b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
@@ -1,14 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_P=${PN}-src-${PV}
inherit toolchain-funcs
+MY_P=${PN}-src-${PV}
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, glide64mk2 video plugin"
HOMEPAGE="https://www.mupen64plus.org/"
-SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+ https://github.com/mupen64plus/mupen64plus-video-glide64mk2/commit/b44b0d1c439bae1cf6c334711ef1ea4d2b565053.patch
+ -> ${P}-boost-1.85.patch
+"
+S=${WORKDIR}/${MY_P}
# TODO: 3dfx licenses
LICENSE="GPL-2+"
@@ -16,21 +21,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gles2-only hires cpu_flags_x86_sse"
-RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
+DEPEND="
+ >=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
media-libs/libpng:0=
media-libs/libsdl2:0=[video]
sys-libs/zlib:0=
virtual/opengl:0=
gles2-only? ( media-libs/libsdl2:0[gles2] )
- hires? ( dev-libs/boost:= )"
-DEPEND="${RDEPEND}"
+ hires? ( dev-libs/boost:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
default
+ # https://github.com/mupen64plus/mupen64plus-video-glide64mk2/commit/b44b0d1c439bae1cf6c334711ef1ea4d2b565053
+ eapply "${DISTDIR}/${P}-boost-1.85.patch"
+
# avoid implicitly appending CPU flags
sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
}