summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/gish-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/gish-demo')
-rw-r--r--games-arcade/gish-demo/Manifest1
-rwxr-xr-xgames-arcade/gish-demo/files/gish-wrapper4
-rw-r--r--games-arcade/gish-demo/gish-demo-1.6.ebuild37
-rw-r--r--games-arcade/gish-demo/metadata.xml5
4 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/gish-demo/Manifest b/games-arcade/gish-demo/Manifest
new file mode 100644
index 000000000000..f32d1c97ec02
--- /dev/null
+++ b/games-arcade/gish-demo/Manifest
@@ -0,0 +1 @@
+DIST gish-demo-1.6.tar.gz 12712912 SHA256 335e28ae5b9f91ebb9487e341d9bb9cf679083a0a3ed5a49daaa27f2b3e3908d SHA512 2d6f37b8a7971ada524c75bafcbe7e92fd3dbb96677774b0295aad2553e6094027f9b43da8318f20071679412f95dd66ab9738178ffec4f853cf1845d536a0a6 WHIRLPOOL d3fb001f01f52df78f39d23994cd6d57558c76c0a94944a3202285860cea5cf0d1eb4ad3f48465d5b3b85e47453a558f66d647ce153cd332d7be429ef0d0ec3e
diff --git a/games-arcade/gish-demo/files/gish-wrapper b/games-arcade/gish-demo/files/gish-wrapper
new file mode 100755
index 000000000000..7f9f4ad53e48
--- /dev/null
+++ b/games-arcade/gish-demo/files/gish-wrapper
@@ -0,0 +1,4 @@
+#!/bin/sh
+export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:."
+export LD_PRELOAD=/usr/lib/libalut.so.0
+exec ./gish "$@"
diff --git a/games-arcade/gish-demo/gish-demo-1.6.ebuild b/games-arcade/gish-demo/gish-demo-1.6.ebuild
new file mode 100644
index 000000000000..9a4e2b67f40c
--- /dev/null
+++ b/games-arcade/gish-demo/gish-demo-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Play as an amorphous ball of tar that rolls and squishes around"
+HOMEPAGE="http://www.chroniclogic.com/gish.htm"
+SRC_URI="http://s159260531.onlinehome.us/demos/gishdemo.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/${PN}/gish"
+
+RDEPEND="media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ x11-libs/libX11
+ >=media-libs/openal-1.6.372"
+
+S=${WORKDIR}/gishdemo
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local gishbin=gishdemo
+ use amd64 && gishbin=gishdemo_64
+
+ insinto "${dir}"
+ doins -r *
+ fperms +x "${dir}"/${gishbin}
+ games_make_wrapper gish ./${gishbin} "${dir}"
+ prepgamesdirs
+}
diff --git a/games-arcade/gish-demo/metadata.xml b/games-arcade/gish-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/gish-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>