summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-25 13:31:33 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-03-25 17:33:04 +0100
commite40c6978e7c5664fc31552aaad4bf91f0099f515 (patch)
tree7c7ff6b26a7e0ec92bbcd9d242170bac8ae9ccda /games-action/trine
parentsys-kernel/gentoo-sources: (diff)
downloadgentoo-e40c6978e7c5664fc31552aaad4bf91f0099f515.tar.gz
gentoo-e40c6978e7c5664fc31552aaad4bf91f0099f515.tar.bz2
gentoo-e40c6978e7c5664fc31552aaad4bf91f0099f515.zip
games-action/trine-bin: Renamed to games-action/trine
This brings it into line with the other Trine packages. It now seems highly unlikely that there will ever be a source release and if it does happen, hopefully we can drop the binary version.
Diffstat (limited to 'games-action/trine')
-rw-r--r--games-action/trine/Manifest1
-rw-r--r--games-action/trine/metadata.xml8
-rw-r--r--games-action/trine/trine-1.08-r2.ebuild77
3 files changed, 86 insertions, 0 deletions
diff --git a/games-action/trine/Manifest b/games-action/trine/Manifest
new file mode 100644
index 000000000000..dd34b082ffeb
--- /dev/null
+++ b/games-action/trine/Manifest
@@ -0,0 +1 @@
+DIST TrineUpdate4.64.run 647258173 BLAKE2B b520d1f312b9bd9ef94f32cd5fbe7ceaea0cb1bd839d8a898ac02cac0eb3464d83588f1163949ca2f53d7badb2eca456b8e1438d6f5e96e3c6baa10ca6cb865a SHA512 1255edc90cfd47c4f5a3cf7fa07cebac047f46f9b5f9f6621baff01d9c4295c95204a695127ce4947038c50c80253e7a004ec1c3accff6ac8697605fd25885f9
diff --git a/games-action/trine/metadata.xml b/games-action/trine/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/trine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/trine/trine-1.08-r2.ebuild b/games-action/trine/trine-1.08-r2.ebuild
new file mode 100644
index 000000000000..99503c9efac8
--- /dev/null
+++ b/games-action/trine/trine-1.08-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils unpacker
+
+DESCRIPTION="A physics-based action game with character-dependent solutions to challenges"
+HOMEPAGE="http://trine-thegame.com/"
+SRC_URI="TrineUpdate4.64.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch strip"
+
+DEPEND="
+ app-admin/chrpath
+ app-arch/unzip
+"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libx86
+ gnome-base/libglade:2.0
+ media-libs/libogg
+ media-libs/libpng:1.2
+ >=media-libs/libsdl-1.2[opengl,sound,video]
+ >=media-libs/libvorbis-1.3
+ >=media-libs/openal-1.15
+ >=media-libs/tiff-3.9:3
+ >=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
+ virtual/jpeg:62
+ x11-libs/gtk+:2
+"
+
+S="${WORKDIR}"
+d="/opt/${PN}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+ rm -v lib*/lib{gcc_s,jpeg,m,ogg,openal,png*,rt,SDL*,selinux,stdc++,tiff,vorbis*}.* || die
+ chrpath --replace "${EPREFIX}${d}"/lib trine-{bin,launcher}$(usex x86 32 64) || die
+}
+
+src_install() {
+ local b bb
+ local sfx=$(usex x86 32 64)
+
+ doicon Trine.xpm
+ for b in bin launcher ; do
+ bb="trine-${b}"
+ exeinto ${d}
+ newexe ${bb}${sfx} ${bb}
+ make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Trine ${b}" Trine
+ done
+
+ exeinto ${d}/lib
+ doexe lib${sfx}/*
+
+ insinto ${d}
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png
+
+ dodoc Trine_Manual_linux.pdf Trine_updates.txt
+}