summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-24 08:49:40 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-24 08:51:32 +0200
commit7ff6511dac94e5d14b4c66b967c8d1f86f48a0f4 (patch)
tree7a088d3e39f52342ef5d8874009887fc0d44f7ab /games-action/multimc-bin
parentdev-java/maven-bin: removed obsolete 3.8.1 (diff)
downloadgentoo-7ff6511dac94e5d14b4c66b967c8d1f86f48a0f4.tar.gz
gentoo-7ff6511dac94e5d14b4c66b967c8d1f86f48a0f4.tar.bz2
gentoo-7ff6511dac94e5d14b4c66b967c8d1f86f48a0f4.zip
games-action/multimc-bin: add -bin version
Because of secret API keys to access MS authentication servers we need a -bin version for full functionality. We also keep the non-bin versions for users who e.g. wish to apply patches https://github.com/MultiMC/MultiMC5/issues/4113 https://github.com/MultiMC/MultiMC5/issues/4087 Closes: https://bugs.gentoo.org/814404 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action/multimc-bin')
-rw-r--r--games-action/multimc-bin/Manifest1
-rw-r--r--games-action/multimc-bin/metadata.xml28
-rw-r--r--games-action/multimc-bin/multimc-bin-1.5.1.ebuild48
3 files changed, 77 insertions, 0 deletions
diff --git a/games-action/multimc-bin/Manifest b/games-action/multimc-bin/Manifest
new file mode 100644
index 000000000000..0e647fe50cbd
--- /dev/null
+++ b/games-action/multimc-bin/Manifest
@@ -0,0 +1 @@
+DIST multimc_1.5-1.deb 7692 BLAKE2B c5b4de864c95cccd96b071d4d551e322eb5c78e17a8da361ee69a82405691c6d9fc81c7eef9dcf855a8e2145fbb362d31c7f63682c7a66edbc37dbf9215e7c1b SHA512 26fe11eff406efd09612002e4c53fc1ea0b3f7d0aca389475a7afff454efa52ed52097f6a0bbc27de61fba3fed252321754738a0f79b0d8a7308a39701087e67
diff --git a/games-action/multimc-bin/metadata.xml b/games-action/multimc-bin/metadata.xml
new file mode 100644
index 000000000000..9246e9cd3415
--- /dev/null
+++ b/games-action/multimc-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">MultiMC/MultiMC5</remote-id>
+ <bugs-to>https://github.com/MultiMC/MultiMC5/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription>
+ MultiMC is a custom launcher for Minecraft that allows you to easily manage multiple installations of Minecraft at once. It also allows you to easily install and remove mods by simply dragging and dropping. Here are the current features of MultiMC:
+
+ - Manage multiple instances of Minecraft at once
+ - Start Minecraft with a custom resolution
+ - Change Java's runtime options (including memory options)
+ - Shows Minecraft's console output in a colour-coded window
+ - Kill Minecraft easily if it crashes/freezes
+ - Custom icons and groups for instances
+ - Forge, Fabric and LiteLoader integration (automatic installation, version downloads, mod management)
+ - Import of Curse modpacks
+ - LWJGL version changing built-in
+ - Supports every version of Minecraft that the vanilla launcher does
+ - Upload screenshots
+ - Import, export Instances allowing you to share with friends and/or make backups
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/multimc-bin/multimc-bin-1.5.1.ebuild b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
new file mode 100644
index 000000000000..2e4e4a210532
--- /dev/null
+++ b/games-action/multimc-bin/multimc-bin-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
+HOMEPAGE="https://multimc.org https://github.com/MultiMC/MultiMC5"
+SRC_URI="https://files.multimc.org/downloads/multimc_$(ver_rs 2 -).deb"
+# We need -bin because of secret API keys:
+# https://github.com/MultiMC/MultiMC5/issues/4087
+# https://github.com/MultiMC/MultiMC5/issues/4113
+# https://bugs.gentoo.org/814404
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ >=virtual/jre-1.8.0
+ virtual/opengl
+ x11-libs/libXrandr
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ # Rename the .desktop file to avoid file conflict with non-bin version
+ mv "${ED}/usr/share/applications/multimc.desktop" "${ED}/usr/share/applications/multimc-bin.desktop" || die
+ # Change the name so we can differentiate from the non-bin version in app menu
+ # and remove empty options
+ sed -i \
+ -e 's/Name=MultiMC 5/Name=MultiMC Official Binary/g' \
+ -e '/Path=/d' \
+ -e '/TerminalOptions=/d' \
+ "${ED}/usr/share/applications/multimc-bin.desktop" || die
+}