summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/descent3-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/descent3-demo')
-rw-r--r--games-action/descent3-demo/Manifest1
-rw-r--r--games-action/descent3-demo/descent3-demo-1.4.0a.ebuild63
-rw-r--r--games-action/descent3-demo/metadata.xml12
3 files changed, 76 insertions, 0 deletions
diff --git a/games-action/descent3-demo/Manifest b/games-action/descent3-demo/Manifest
new file mode 100644
index 000000000000..ec5774ba32d3
--- /dev/null
+++ b/games-action/descent3-demo/Manifest
@@ -0,0 +1 @@
+DIST descent3-demo.run 45118289 SHA256 9304dff200a062bb5bd1fa69517b5cc6c19db0a63c06b2084f05c98c9eca786c SHA512 8f5e790257d0477e4238aae8fb5b4b1f21e23f188775cb53a5197baf0c174017d821e3a8dd696f9c0fd27838e08cff4bde0d6f5a9dca87a7e8af29cdc627d29c WHIRLPOOL 42d4aabadf185fe88e9e2dff91595a8895a2f51e212e7efbdcaccb9b55d380c10a3fbb0e4c5c2814d3017e0d90ba46c70a2d770bc7a8cbe25b6fc210a0a4204c
diff --git a/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild b/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild
new file mode 100644
index 000000000000..cf1e1ee7ad37
--- /dev/null
+++ b/games-action/descent3-demo/descent3-demo-1.4.0a.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Indoor/outdoor 3D combat with evil robotic mining spacecraft"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+dir="${GAMES_PREFIX_OPT}/${PN}"
+QA_PREBUILT="${dir:1}/descent3_demo.x86
+ ${dir:1}/netgames/*.d3m"
+
+S=${WORKDIR}
+
+src_install() {
+ local demo="data/demos/descent3_demo"
+ local exe="descent3_demo.x86"
+
+ loki_patch patch.dat data/ || die
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ doexe "${demo}/${exe}"
+
+ # Required directory
+ keepdir "${dir}"/missions
+
+ # Fix for 2.6 kernel crash
+ cd "${Ddir}"
+ ln -sf ppics.hog PPics.Hog
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}"
+ newicon "${demo}"/launch/box.png ${PN}.png
+ make_desktop_entry ${PN} "Descent 3 (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " descent3-demo"
+ elog
+ elog "If the game appears blank, then run it windowed with:"
+ elog " descent3-demo -w"
+ echo
+}
diff --git a/games-action/descent3-demo/metadata.xml b/games-action/descent3-demo/metadata.xml
new file mode 100644
index 000000000000..799357326bea
--- /dev/null
+++ b/games-action/descent3-demo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Descent 3 is a first-person 3-D action flight-sim which takes place in both
+indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki
+Entertainment and is commercial software. You can still pick up a copy from
+Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher
+is no longer in business. This is the free demo version of the full game.
+</longdescription>
+</pkgmetadata>