summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-19 13:53:41 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-19 14:07:57 +0200
commitfbc6d2cd97278c3ce27bbf6a8fc532796b3fc32c (patch)
tree3b339fc8b6dbe6970c5f3116a0ab8aa760fdb6d2 /eclass
parentmedia-tv/mythtv: fix broken qmake detection for qt5 (diff)
downloadgentoo-fbc6d2cd97278c3ce27bbf6a8fc532796b3fc32c.tar.gz
gentoo-fbc6d2cd97278c3ce27bbf6a8fc532796b3fc32c.tar.bz2
gentoo-fbc6d2cd97278c3ce27bbf6a8fc532796b3fc32c.zip
kde5-functions.eclass: punt_bogus_deps improvements
Syncs eclass with kde overlay. Improvements by Michael Palimaka <kensington@gentoo.org>. Needed for bug #580282.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde5-functions.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index be336bec8b10..44bc29631a56 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -274,7 +274,7 @@ punt_bogus_dep() {
sed -e "${first},${last}s/${dep}//" -i CMakeLists.txt || die
if [[ ${length} = 1 ]] ; then
- sed -e "/find_package\s*(\s*${prefix}\s*\(REQUIRED\)*\s*\(COMPONENTS\)*\s*)/I d" -i CMakeLists.txt || die
+ sed -e "/find_package\s*(\s*${prefix}\(\s\+\(REQUIRED\|CONFIG\|COMPONENTS\|\${KF5_VERSION}\)\)\+\s*)/Is/^/# removed by kde5-functions.eclass - /" -i CMakeLists.txt || die
fi
}