summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-05 18:43:03 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-05 18:43:03 -0400
commite2bc7ce5cdf40a450d9077c7e73267974ec30cad (patch)
tree54625f838706b1131588fb8210beb9f12284cbf0 /dev-vcs
parentdev-vcs/gitinspector: remove unused versions 0.3.1 and 0.3.2. (diff)
downloadgentoo-e2bc7ce5cdf40a450d9077c7e73267974ec30cad.tar.gz
gentoo-e2bc7ce5cdf40a450d9077c7e73267974ec30cad.tar.bz2
gentoo-e2bc7ce5cdf40a450d9077c7e73267974ec30cad.zip
dev-vcs/gitinspector: new version 0.4.4.
New version, new EAPI, and some fixes to the install process. Some docs were being missed, and others installed to the wrong place. All better now. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitinspector/Manifest2
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.2.ebuild26
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.4.ebuild42
3 files changed, 43 insertions, 27 deletions
diff --git a/dev-vcs/gitinspector/Manifest b/dev-vcs/gitinspector/Manifest
index c7925e64c5de..9818beaf5735 100644
--- a/dev-vcs/gitinspector/Manifest
+++ b/dev-vcs/gitinspector/Manifest
@@ -1 +1 @@
-DIST gitinspector-0.4.2.tar.gz 312781 SHA256 4c10d2a6a7964f0a38bd7fa8429f3d5095bf56d829c07a38256810cae0793f55 SHA512 144f2cf03f7cb426ccb9a28a6328bd54e6f13cf56d255829a78f31292be63d3f91dcd76525b1bdee514aff7ec20869acae9dc1f0683261ca9bbab29e660cc915 WHIRLPOOL 95fea80bf15f26d6147acca63a80786443a5d4bc6a35710825e73eed13e49212eab9535757f9b0958fec18ed5513a2905839e961631f77e0c9a8ccb816557505
+DIST gitinspector-0.4.4.tar.gz 312201 SHA256 c7a50772bf675d41b7c19508d8f2ea26725ce4ae16aba709d5b42db42e3d2459 SHA512 6e453a97f7b0bda73e376499268d9a46aa4ff1f8bb65092314a6d32031b0292056152b4e0e3781fbbe3aa6150373679bf78a8c83410882921ab40ce6d356fadb WHIRLPOOL d4c10d1d43296908e0c8463a23d9cd0c5178ea9513d10c1519b250e738357ec9dc4ee259552445a43b6eb2d061480bff51633e01ac5938bf01e0e05cd569d5af
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild
deleted file mode 100644
index 736348dafc33..000000000000
--- a/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical analysis tool for git repositories"
-HOMEPAGE="https://github.com/ejwa/gitinspector"
-SRC_URI="https://github.com/ejwa/gitinspector/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-vcs/git"
-DEPEND="
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
- distutils-r1_python_prepare_all
-}
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
new file mode 100644
index 000000000000..8a2f93873ec8
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://github.com/ejwa/gitinspector"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+
+ # Otherwise this gets installed with the *.txt glob.
+ rm LICENSE.txt || die 'failed to remove LICENSE.txt'
+
+ # Use /usr/share/doc/${PF} instead of /usr/share/doc/${PN}.
+ sed -i setup.py \
+ -e "s:share/doc/gitinspector:share/doc/${PF}:" \
+ || die 'failed to fix the documentation path in setup.py'
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # The distutils install routine misses some important documentation.
+ doman docs/gitinspector.1
+ dodoc docs/*.{pdf,css,html,txt}
+}