summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-03-11 22:50:00 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-03-12 17:17:24 +0200
commitc14c17d80f0fcdd788ce03f981db3b0e83caa6cf (patch)
tree4c869c6feafd977cfa9d766432f18d0719f2b9cb /dev-vcs
parentdev-vcs/tortoisehg: 5.7 add PYTHON_COMPAT python3_9 (diff)
downloadgentoo-c14c17d80f0fcdd788ce03f981db3b0e83caa6cf.tar.gz
gentoo-c14c17d80f0fcdd788ce03f981db3b0e83caa6cf.tar.bz2
gentoo-c14c17d80f0fcdd788ce03f981db3b0e83caa6cf.zip
dev-vcs/tortoisehg: live, add PYTHON_COMPAT python3_9
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/19883 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 770dffc99f7d..439a13c2c812 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=no
@@ -11,13 +11,13 @@ inherit desktop distutils-r1 xdg-utils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-5.6
- <dev-vcs/mercurial-5.8"
+ HG_DEPEND=">=dev-vcs/mercurial-5.6[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]"
else
inherit mercurial
EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
EHG_REVISION="stable"
- HG_DEPEND=">=dev-vcs/mercurial-5.6"
+ HG_DEPEND=">=dev-vcs/mercurial-5.6[${PYTHON_USEDEP}]"
fi
DESCRIPTION="Set of graphical tools for Mercurial"