summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-10 23:17:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-10 23:19:06 +0300
commit9e7e88c20f804d3b515792fb523ea397586efcfe (patch)
tree3c32752ed1358e6b59b9078959d2c875a743dff9 /dev-vcs
parentdev-python/merge3: new package, add 0.0.13 (diff)
downloadgentoo-9e7e88c20f804d3b515792fb523ea397586efcfe.tar.gz
gentoo-9e7e88c20f804d3b515792fb523ea397586efcfe.tar.bz2
gentoo-9e7e88c20f804d3b515792fb523ea397586efcfe.zip
dev-vcs/breezy: fix missing RDEPs, fix strip call
Closes: https://bugs.gentoo.org/910051 Closes: https://bugs.gentoo.org/909846 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/breezy/breezy-3.3.0-r1.ebuild (renamed from dev-vcs/breezy/breezy-3.3.0.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-vcs/breezy/breezy-3.3.0.ebuild b/dev-vcs/breezy/breezy-3.3.0-r1.ebuild
index 305f328287e7..42bcca42b2ce 100644
--- a/dev-vcs/breezy/breezy-3.3.0.ebuild
+++ b/dev-vcs/breezy/breezy-3.3.0-r1.ebuild
@@ -65,11 +65,12 @@ RESTRICT="test"
RDEPEND="
$(python_gen_cond_dep '
dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/dulwich[${PYTHON_USEDEP}]
- dev-python/fastimport[${PYTHON_USEDEP}]
- dev-python/patiencediff[${PYTHON_USEDEP}]
dev-python/fastbencode[${PYTHON_USEDEP}]
+ dev-python/patiencediff[${PYTHON_USEDEP}]
+ dev-python/merge3[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
')
!dev-vcs/bzr
"
@@ -84,7 +85,9 @@ BDEPEND="
QA_FLAGS_IGNORED=".*"
src_prepare() {
- sed -e 's@man/man1@share/&@' -i setup.py || die
+ sed -e 's@man/man1@share/&@' \
+ -e 's@, strip=Strip\.All@@' \
+ -i setup.py || die
distutils-r1_src_prepare
}