summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-10 11:59:35 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-10 11:59:45 +0000
commit26c9933a73f18482bf3a4ef04f07b2f2ce1f7708 (patch)
treeb315a928206f525eb5402526fa854f67397dba0e /dev-vcs/cvsps
parentmedia-sound/xmms2-scrobbler: refresh up to EAPI=7 (diff)
downloadgentoo-26c9933a73f18482bf3a4ef04f07b2f2ce1f7708.tar.gz
gentoo-26c9933a73f18482bf3a4ef04f07b2f2ce1f7708.tar.bz2
gentoo-26c9933a73f18482bf3a4ef04f07b2f2ce1f7708.zip
dev-vcs/cvsps: refresh up to EAPI=7
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs/cvsps')
-rw-r--r--dev-vcs/cvsps/cvsps-3.13-r2.ebuild (renamed from dev-vcs/cvsps/cvsps-3.13-r1.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-vcs/cvsps/cvsps-3.13-r1.ebuild b/dev-vcs/cvsps/cvsps-3.13-r2.ebuild
index 45e63d4b5dc4..1d9ca2cea5f5 100644
--- a/dev-vcs/cvsps/cvsps-3.13-r1.ebuild
+++ b/dev-vcs/cvsps/cvsps-3.13-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit eutils toolchain-funcs
@@ -20,10 +20,13 @@ DEPEND="${RDEPEND}
RESTRICT=test # upstream does not ship tests
+PATCHES=("${FILESDIR}"/${P}-make.patch)
+
src_prepare() {
+ default
+
local gentoo_name=${PN}-3
- epatch "${FILESDIR}"/${P}-make.patch
mv ${PN}.asc ${gentoo_name}.asc || die
sed -i "s/${PN}/${gentoo_name}/g" ${gentoo_name}.asc || die
sed -i "s/PROG = cvsps/PROG = ${gentoo_name}/" Makefile || die
@@ -34,5 +37,6 @@ src_prepare() {
src_install() {
default
+
dodoc README
}