summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-17 17:09:31 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:28:46 -0400
commit6e8f459c48bf0125a1b56adcadd6855cad7d34d4 (patch)
treeba3a3fb1bdc485409c2382d5e0851d8d2282943d /dev-util/sysprof-capture
parentgui-libs/libpanel: Version bump to 1.2.0 (diff)
downloadgentoo-6e8f459c48bf0125a1b56adcadd6855cad7d34d4.tar.gz
gentoo-6e8f459c48bf0125a1b56adcadd6855cad7d34d4.tar.bz2
gentoo-6e8f459c48bf0125a1b56adcadd6855cad7d34d4.zip
dev-util/sysprof-capture: Version bump to 3.48.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index 595615bf0871..46c28dad2dea 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,2 +1,3 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.46.0.tar.xz 518536 BLAKE2B 8925f0cbe34411cce6bd86e9f4a924d3ff627429812682898fffe0a08c2dab9228e5d8bde44b460404f90fb29961a30154af1e8240df24bfa20b70cc7a36448e SHA512 ac248e2a06d2f7905bebae4e685dd320e3ac85097e33b9c6b8482a4647a5bfcaadc4d9a1fe117b3a74cb855d6c72d9a1453a37d7b64762a223c0fe5da2653a87
+DIST sysprof-3.48.0.tar.xz 533092 BLAKE2B 5af48d9216f13ffcc8824b0ba6a4e0ff931c903991953e66c2b50534399320d3d3fccd6e8478b10dc895d19544f9c08733565d95fe9c2c70d64f2294ccce2330 SHA512 100b79fabee005b5445dab3ad78d43facf375a488aa6513e987deecd6a3036cc43bfd78db106a4b8a15b4280dcd975872784c839f560779183adb5a339b0648c
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild
new file mode 100644
index 000000000000..f2e417f40bd4
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.48.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgtk=false
+ -Dlibsysprof=false
+ -Dinstall-static=true
+ -Dsysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Dtools=false
+ -Dtests=false
+ -Dexamples=false
+ -Dagent=false
+ )
+ meson_src_configure
+}