summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-21 10:54:12 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-21 10:56:22 +0200
commit9787a7dd622e2f3c8adfc78791c270e512b9b510 (patch)
treebd291bfcb913aa375ddd9bd695408f918cfc4143 /dev-util/squashmerge
parentdev-util/squashmerge: Moved to GitHub (diff)
downloadgentoo-9787a7dd622e2f3c8adfc78791c270e512b9b510.tar.gz
gentoo-9787a7dd622e2f3c8adfc78791c270e512b9b510.tar.bz2
gentoo-9787a7dd622e2f3c8adfc78791c270e512b9b510.zip
dev-util/squashmerge: Modernize the live ebuild, EAPI=6
Diffstat (limited to 'dev-util/squashmerge')
-rw-r--r--dev-util/squashmerge/squashmerge-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/dev-util/squashmerge/squashmerge-9999.ebuild b/dev-util/squashmerge/squashmerge-9999.ebuild
index 4db734886acf..14b136be6184 100644
--- a/dev-util/squashmerge/squashmerge-9999.ebuild
+++ b/dev-util/squashmerge/squashmerge-9999.ebuild
@@ -1,31 +1,20 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils
+inherit autotools git-r3
DESCRIPTION="dev-util/squashdelta delta merge tool"
HOMEPAGE="https://github.com/mgorny/squashmerge/"
-SRC_URI="https://www.github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="lz4 +lzo"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-#endif
-
COMMON_DEPEND="
lz4? ( app-arch/lz4:0= )
lzo? ( dev-libs/lzo:2= )"
@@ -38,11 +27,16 @@ REQUIRED_USE="|| ( lz4 lzo )"
DOCS=( FORMAT )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable lz4)
$(use_enable lzo)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}