summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/gtk-doc-am
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/gtk-doc-am')
-rw-r--r--dev-util/gtk-doc-am/Manifest2
-rw-r--r--dev-util/gtk-doc-am/gtk-doc-am-1.21.ebuild50
-rw-r--r--dev-util/gtk-doc-am/gtk-doc-am-1.24.ebuild50
-rw-r--r--dev-util/gtk-doc-am/metadata.xml5
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/gtk-doc-am/Manifest b/dev-util/gtk-doc-am/Manifest
new file mode 100644
index 000000000000..9bb6d3238c39
--- /dev/null
+++ b/dev-util/gtk-doc-am/Manifest
@@ -0,0 +1,2 @@
+DIST gtk-doc-1.21.tar.xz 647484 SHA256 5d934d012ee08edd1585544792efa80da271652587ba5b843d2cea8e8b80ee3e SHA512 caef8f6fd42f2961b6703af6d8b9f003b6e6ba2e9e955b94d9c0ecce8d267b7f4c2315d273dbdca1aff244e81867e675434b09a9410248e93101e86105f60f9d WHIRLPOOL cd72184e6f58745573d8bec785b0a8c61f3f68ff9c20254dd6a03e113aeac1672a8408f03c84918c523e2031a98fd5d75990d9377ea8444c2ce7fdba03dfaccc
+DIST gtk-doc-1.24.tar.xz 669664 SHA256 b420759ea05c760301bada14e428f1b321f5312f44e10a176d6804822dabb58b SHA512 a0095efed339cb101dcd947fdc1789edd4a59d7005f6328c68973133795e34819fffdccb4591725b78f8409be95158604387deb681e78ebce0356503de1377a4 WHIRLPOOL b0af2db253147dbf58738e5e66964e6b2000cd3d30f3ef138c81d544a6c12ba2a3b32f71acf3b7677c8562fe945b1d63fe212b99b4f4bb53ccd256bcacb9ad71
diff --git a/dev-util/gtk-doc-am/gtk-doc-am-1.21.ebuild b/dev-util/gtk-doc-am/gtk-doc-am-1.21.ebuild
new file mode 100644
index 000000000000..a39804d8911f
--- /dev/null
+++ b/dev-util/gtk-doc-am/gtk-doc-am-1.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_ORG_MODULE="gtk-doc"
+
+inherit gnome.org
+
+DESCRIPTION="Automake files from gtk-doc"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6"
+DEPEND="${RDEPEND}
+ !<dev-util/gtk-doc-${GNOME_ORG_PVP}
+"
+# pkg-config is used by gtkdoc-rebase at runtime
+# PDEPEND to avoid circular deps, bug 368301
+PDEPEND="virtual/pkgconfig"
+
+# This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
+RESTRICT="test"
+
+src_configure() {
+ # Duplicate autoconf checks so we don't have to call configure
+ local PERL=$(type -P perl)
+
+ test -n "${PERL}" || die "Perl not found!"
+ "${PERL}" -e "require v5.6.0" || die "perl >= 5.6.0 is required for gtk-doc"
+
+ # Replicate AC_SUBST
+ sed -e "s:@PERL@:${PERL}:g" -e "s:@VERSION@:${PV}:g" \
+ "${S}/gtkdoc-rebase.in" > "${S}/gtkdoc-rebase" || die "sed failed!"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin gtkdoc-rebase
+
+ insinto /usr/share/aclocal
+ doins gtk-doc.m4
+}
diff --git a/dev-util/gtk-doc-am/gtk-doc-am-1.24.ebuild b/dev-util/gtk-doc-am/gtk-doc-am-1.24.ebuild
new file mode 100644
index 000000000000..5421066fb5c5
--- /dev/null
+++ b/dev-util/gtk-doc-am/gtk-doc-am-1.24.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_ORG_MODULE="gtk-doc"
+
+inherit gnome.org
+
+DESCRIPTION="Automake files from gtk-doc"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6"
+DEPEND="${RDEPEND}
+ !<dev-util/gtk-doc-${GNOME_ORG_PVP}
+"
+# pkg-config is used by gtkdoc-rebase at runtime
+# PDEPEND to avoid circular deps, bug 368301
+PDEPEND="virtual/pkgconfig"
+
+# This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
+RESTRICT="test"
+
+src_configure() {
+ # Duplicate autoconf checks so we don't have to call configure
+ local PERL=$(type -P perl)
+
+ test -n "${PERL}" || die "Perl not found!"
+ "${PERL}" -e "require v5.6.0" || die "perl >= 5.6.0 is required for gtk-doc"
+
+ # Replicate AC_SUBST
+ sed -e "s:@PERL@:${PERL}:g" -e "s:@VERSION@:${PV}:g" \
+ "${S}/gtkdoc-rebase.in" > "${S}/gtkdoc-rebase" || die "sed failed!"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin gtkdoc-rebase
+
+ insinto /usr/share/aclocal
+ doins gtk-doc.m4
+}
diff --git a/dev-util/gtk-doc-am/metadata.xml b/dev-util/gtk-doc-am/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-util/gtk-doc-am/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>