summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-05-30 15:58:50 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-05-30 15:59:14 -0500
commit943ac1d6bac11016ea7f4ff8d0443d5981230763 (patch)
treedbf563e5d1d44945e64b49ec554d5180b3c493b1 /dev-util/gitlab-runner
parentsys-kernel/gentoo-kernel-bin: Bump to 5.15.114 (diff)
downloadgentoo-943ac1d6bac11016ea7f4ff8d0443d5981230763.tar.gz
gentoo-943ac1d6bac11016ea7f4ff8d0443d5981230763.tar.bz2
gentoo-943ac1d6bac11016ea7f4ff8d0443d5981230763.zip
dev-util/gitlab-runner: add 16.0.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.0.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 4ad3f4da2ccb..9276ba7af332 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-15.11.1-deps.tar.xz 161358304 BLAKE2B a318aa741a29c3e1623a389
DIST gitlab-runner-15.11.1.tar.bz2 1343959 BLAKE2B 3c1a12aedb6ec4ba88b20f1aca30e2cae3acbfab7aa22ab91cc87c355e1f1926f27c70a0357be6f969634bca200a7b9e69fb2bd09403be21d7fc4383c48d951f SHA512 5756952adf79a72ba62eef7e28d4dd134fd1aa00a020c615a11fcd6d8fadeb2ba40cf8e20d8bc253082885ea8fe77f18124da35fb7fa5f7bc7360b8143a85cd3
DIST gitlab-runner-15.9.1-deps.tar.xz 159144912 BLAKE2B f10167c731371dbf4d61a05d9154a3127e286846fd60e2eb7291a587d707389fdb989526942263e7a7fac2af02fc343e316528ee2f64aaf97a048e83e58521f9 SHA512 ae74bbfa62ac4a7506ec6099fab11bcf66f7b270ccc0a17dde0b226cccdbaf51949bea44f437e97c20e4b60c605060b42e77a36a11fb5eb080d55dcf30ee58d5
DIST gitlab-runner-15.9.1.tar.bz2 1267756 BLAKE2B 1732db4d7d8a3f530654f2897ec665bef87cefbfafc8776ba4b15d327768924d9fef5918a5d31899825e17bba20d04bfd30f6c8cbe834b266cadd0f414cfe840 SHA512 ab82cce1956105046aba8560317e00f3f333669ca7ee305879821bf433485599d2eb206afd8edc04c3b9c3d07eb38dfe335c77ff9a4f431bee5dea0a1d10b9c2
+DIST gitlab-runner-16.0.1-deps.tar.xz 161414860 BLAKE2B 10aeed685269102aae8a738b87c29fc553ddf3ca14309c7634180d9909d943a94727df851f0374dd0ae6c0b221a54bbd48a0fa38047cb50d1ca08798872c0ec0 SHA512 9337002f9a3c1356db11d635d767826aae719ccf546da77a3aec4c9d6eba253398a237f517d0a48aef60021d8d9a303656ac3bda4c5a282dc219034c8e704e88
+DIST gitlab-runner-16.0.1.tar.bz2 1345390 BLAKE2B 2c2bce5444721786014b0830149a7c430f5bc76b1f90df1b1b988788b4b43a79494419758f64ac56ca582ce9ffb214bfc9426bf8d9d2f1c51e09bb26a213406f SHA512 aa45659f958361d8fa138cf496faa68b278084127a225cf56930bd040db2b20307bcfe98c230ecc6d6f7576fbebebb6aa5801a4d17de2a977c92fa2ddf28ee84
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.0.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.0.1.ebuild
new file mode 100644
index 000000000000..68b04dc38d08
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=79704081
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}