summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-23 12:12:28 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-23 12:13:49 -0600
commit4156e36fd11026dabd2fd96583cf215d3187dab3 (patch)
tree9238f715e487646a9605fddd005874bdd9daeca4 /dev-util/gitlab-runner
parentsys-cluster/galera: Stabilize 26.4.13 ppc64, #891837 (diff)
downloadgentoo-4156e36fd11026dabd2fd96583cf215d3187dab3.tar.gz
gentoo-4156e36fd11026dabd2fd96583cf215d3187dab3.tar.bz2
gentoo-4156e36fd11026dabd2fd96583cf215d3187dab3.zip
dev-util/gitlab-runner: add 15.8.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.8.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index c6cb6ca605d7..55f463d8bf6a 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-15.6.2-deps.tar.xz 160098068 BLAKE2B b312f78c79a2ed47a6d52443
DIST gitlab-runner-15.6.2.tar.bz2 1237158 BLAKE2B 2466e2688626e70cbb46386d9f963c95b1ac3fa6d5dbeeca02917524530588ad69e73cfe54adb1c70de1aa4eaa0599d8f9558fdc72432c87de2d6382ad56f060 SHA512 b9fce864b52ecc49441c4714beb9b6584cd30c1d55d3fea3e188b3154bd33931601111c4c869f354a75f97aeb803c68f8f1a3faa6c0b4d62ba85853f28ccdd25
DIST gitlab-runner-15.7.2-deps.tar.xz 160595944 BLAKE2B e0e942a2bf41b0f9092ff3c8670a0cc2a9dbcd961e89efb802f46c05f4d69c68db3c611ce16cafba4240419077b6021747d2b5f0c625c0a6975282a27c54482d SHA512 97bd14b384f49ec4b9c0e2a38597b86da45897d6a1bb61c0f2abf9e80f0f22aa07d17668599b7be340f3ffca8d340df51d50793d1b971ec1c6a0b798b97c1fec
DIST gitlab-runner-15.7.2.tar.bz2 1249827 BLAKE2B 9f83fe67453a086f10d0451637c3195ae6c0440f0606af4fb6b81fa4a019e67d5b916155e1674af9e28ccc52fb2ff6ad4b4783961731fb314c2ba35652648714 SHA512 f5ffd9dfee82cd6d41ab886af995a2479e08c2f5a182a135d84247a7644b2f32cfd77f803266eeebb8c244c4cb0b9cb8a1a7dc5aaef2b181e2b6085dce62d046
+DIST gitlab-runner-15.8.0-deps.tar.xz 160683188 BLAKE2B 38a3fe7e527553cc53382338ecb52d2a3c8c94b72b04d0d3dfa01e4b4953c9a73fb71982daa60f6ea735c77c6d18d78f40381fce9d9f261ad3d8d5cab527bdf8 SHA512 3e412e20cbdd76d896e2e3b40fe8558de1eea69fae1649a91c04ec7f16afcdc0611aa033fab49334ccb5fc0a6c4062c3de858f0419b93a8b10896176f2ff58db
+DIST gitlab-runner-15.8.0.tar.bz2 1256911 BLAKE2B 309f98898a122b82f107e286ef3212e7b3e1345e8ba4486b9e02e10da717ba71b08f2075a2f6ddedf5d64506954f65754410e30bc729f0cf005ad8845912e72b SHA512 4239218aaf53db3020f5eb6edc17014b7d7550093bc9a4b545216eb1f2e155c77418eb2d5cf2ec1c1554664b6763354cd8d5fcb3d3ffbaeb6839b4282be76cdf
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.8.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.8.0.ebuild
new file mode 100644
index 000000000000..dcc12af4183b
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=12335144
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}