summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-09 20:11:41 +0100
committerSam James <sam@gentoo.org>2022-08-09 21:05:45 +0100
commit8210760f7825a652ab094e6c6e3e83562aceceec (patch)
tree968013e76d597fbb20a9c90a78f34be79d31bfb0 /dev-util/dialog
parentsys-apps/iucode_tool: add argp-standalone dep for musl (diff)
downloadgentoo-8210760f7825a652ab094e6c6e3e83562aceceec.tar.gz
gentoo-8210760f7825a652ab094e6c6e3e83562aceceec.tar.bz2
gentoo-8210760f7825a652ab094e6c6e3e83562aceceec.zip
dev-util/dialog: add 1.3.20220728
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/dialog')
-rw-r--r--dev-util/dialog/Manifest1
-rw-r--r--dev-util/dialog/dialog-1.3.20220728.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index b239210955cb..1dd7ad8147b1 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,2 +1,3 @@
DIST dialog-1.3-20220414.tgz 566701 BLAKE2B d3fba0e896d51048876cd1c393d1f2183e47c5307d218dea0bf8c9cbaaed198bfc39e40e1f52b12c978dda10fa61be75d2527c293da652d2f83b80a2237d9d2f SHA512 53b7bc64bb6406c5828f2d023e7db457eee970ade2077bc64860ef12f06c254b4a13706eee068ffe44055ec6b0576ecfe33153438660a5a54f78ea1be00091ee
DIST dialog-1.3-20220526.tgz 567657 BLAKE2B 1b46c0310e54f26cf5efcd8c84d9b8ef3d7ba7b58292c0967559e4bf281a0312185d3f9dea090e01a95a096ee1781bcdcbab11552175c8d6154ac9268654b6d8 SHA512 619d52b8123264bf586f5325443c3b85863166119c6fbaa91571a57454d761f01a53ebeb2203ea725c83dc88f2abf886c64c6eac5b56c126e4f3939eb1d24d62
+DIST dialog-1.3-20220728.tgz 568086 BLAKE2B 086d946f2a8d298f1d26a193b5e99c00991a7f25fb032efef77109b20deaf08d54562673132bfa458d0c28360b2271e7ec50611ebe00e0c1584f178c0d8d7254 SHA512 dddceaf00bfec4b53f2cf67e51d4c54841d9db337536657c21bc8f324a0eb9c6d621f00e09bfb741bd263f171dde38cfea87568f86daf04a9e88575a0ed61218
diff --git a/dev-util/dialog/dialog-1.3.20220728.ebuild b/dev-util/dialog/dialog-1.3.20220728.ebuild
new file mode 100644
index 000000000000..8e2f0156722a
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20220728.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${PN}-$(ver_rs 2 -)
+
+DESCRIPTION="Tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://invisible-island.net/archives/dialog/${MY_P}.tgz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples minimal nls unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5:=[unicode(+)?]"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+BDEPEND="!minimal? ( sys-devel/libtool )
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ export ac_cv_prog_LIBTOOL=glibtool
+ fi
+
+ econf \
+ --disable-rpath-hack \
+ --with-pkg-config \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts='-shared' \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ find "${ED}" -name '*.la' -delete || die
+}