summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-11 19:13:22 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-11 19:13:36 +0100
commit7e08515bd66a0365ac2e1b41f9c92faedd36c350 (patch)
tree92e0364a8b202d971c16cc5836753821a2e6424f /dev-util/csup
parentdev-python/mypy: Take ownership of mypy. (diff)
downloadgentoo-7e08515bd66a0365ac2e1b41f9c92faedd36c350.tar.gz
gentoo-7e08515bd66a0365ac2e1b41f9c92faedd36c350.tar.bz2
gentoo-7e08515bd66a0365ac2e1b41f9c92faedd36c350.zip
dev-util/csup: EAPI 6 bump.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util/csup')
-rw-r--r--dev-util/csup/csup-20060318-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/csup/csup-20060318-r1.ebuild b/dev-util/csup/csup-20060318-r1.ebuild
new file mode 100644
index 000000000000..4bd23eb5dced
--- /dev/null
+++ b/dev-util/csup/csup-20060318-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A rewrite of CVSup"
+HOMEPAGE="http://www.mu.org/~mux/csup.html"
+SRC_URI="http://mu.org/~mux/csup-snap-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+DEPEND="
+ sys-libs/zlib:0=
+ dev-libs/openssl:0="
+
+RDEPEND="
+ ${DEPEND}
+ !>=sys-freebsd/freebsd-ubin-6.2_beta1"
+
+DEPEND="
+ ${DEPEND}
+ >=sys-devel/bison-2.1"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${P}-respectflags.patch")
+
+src_compile() {
+ # unable to work with yacc, but bison is ok.
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX=/usr \
+ YACC=bison
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}