summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-01-14 20:41:09 +0100
committerFabian Groffen <grobian@gentoo.org>2022-01-14 20:41:28 +0100
commitb5277dffbe654139fcec7f892786cfa145aa05f9 (patch)
tree0979e9a9c895007c64032e4d87565c0e2576ff64 /dev-util/colm
parentkde-plasma/ksysguard: EAPI-8 bump, minor upstream backports (diff)
downloadgentoo-b5277dffbe654139fcec7f892786cfa145aa05f9.tar.gz
gentoo-b5277dffbe654139fcec7f892786cfa145aa05f9.tar.bz2
gentoo-b5277dffbe654139fcec7f892786cfa145aa05f9.zip
dev-util/colm-0.14.7-r1: add patch for Solaris
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-util/colm')
-rw-r--r--dev-util/colm/colm-0.14.7-r1.ebuild3
-rw-r--r--dev-util/colm/files/colm-0.14.7-solaris.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-util/colm/colm-0.14.7-r1.ebuild b/dev-util/colm/colm-0.14.7-r1.ebuild
index 831d5bc521f1..1af0b8772742 100644
--- a/dev-util/colm/colm-0.14.7-r1.ebuild
+++ b/dev-util/colm/colm-0.14.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ RDEPEND="!<dev-util/ragel-7.0.3"
PATCHES=(
"${FILESDIR}"/${PN}-0.14.7-drop-julia-check.patch
"${FILESDIR}"/${PN}-0.14.7-disable-static-lib.patch
+ "${FILESDIR}"/${PN}-0.14.7-solaris.patch
)
src_prepare() {
diff --git a/dev-util/colm/files/colm-0.14.7-solaris.patch b/dev-util/colm/files/colm-0.14.7-solaris.patch
new file mode 100644
index 000000000000..83b03b0d23a1
--- /dev/null
+++ b/dev-util/colm/files/colm-0.14.7-solaris.patch
@@ -0,0 +1,28 @@
+https://github.com/adrian-thurston/colm/pull/145
+
+commit 0a0fa0a41928564fa92100bff1bc21f85d770bfb
+Author: Fabian Groffen <grobian@gentoo.org>
+Date: Wed Jan 12 20:32:44 2022 +0100
+
+ src/bytecode.c: include config.h to activate guards
+
+ Fix compilation on Solaris, which needs sys/wait.h for macros like
+ WEXITSTATUS.
+
+ Signed-off-by: Fabian Groffen <grobian@gentoo.org>
+
+diff --git a/src/bytecode.c b/src/bytecode.c
+index 8ef848b0..c30778da 100644
+--- a/src/bytecode.c
++++ b/src/bytecode.c
+@@ -20,6 +20,10 @@
+ * SOFTWARE.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <colm/bytecode.h>
+
+ #include <sys/types.h>