summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-08-18 10:48:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-21 21:37:14 +0300
commit58b73dc815b18493e639f2362c8d01fa1943db41 (patch)
treedf67a2b58570f3dbf411ef1b491455ed21aa11f0 /dev-util/codespell
parentdev-python/moto: add 4.0.0 (diff)
downloadgentoo-58b73dc815b18493e639f2362c8d01fa1943db41.tar.gz
gentoo-58b73dc815b18493e639f2362c8d01fa1943db41.tar.bz2
gentoo-58b73dc815b18493e639f2362c8d01fa1943db41.zip
dev-util/codespell: add 2.2.1
Closes: https://bugs.gentoo.org/865671 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/26909 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/codespell')
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.2.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
index c0fb3621378b..b21bfef729c9 100644
--- a/dev-util/codespell/Manifest
+++ b/dev-util/codespell/Manifest
@@ -1 +1,2 @@
DIST codespell-2.1.0.tar.gz 187490 BLAKE2B 6114aa3a7ad8cd37ab868a3f27f641501dd0cc5bfe80bef0aa5cad0a86f8e2bba6e1f1030d5ac6fb06f78f9e01e37359d0fc17d17eb54608060300f676d3d56c SHA512 16d9a4239ae18fad6a06825a2afae6adc903d50eb90b759cdc61b1e1d145458bbfb1385837c4465b0a9858da100be074c597343c4816ca0260bbf6710d9c84e8
+DIST codespell-2.2.1.tar.gz 211593 BLAKE2B aba431119fd1f16ee51076cd4496ef3f3e80e56a124bbbd4ebbec5dcee5b7e49788db37bcdefd15946d12680596b33ab20ae845fd9a3a3a61ee8c3eed187fe2f SHA512 6c1ce9ed134ba4602cc91c1851a023911ff09ce7d4b1e8a33e655bf821a5b82ae8f0e75defef43e9a8537a6ffc7f0ad7e59af7b200a1294dfe3aff1651869e41
diff --git a/dev-util/codespell/codespell-2.2.1.ebuild b/dev-util/codespell/codespell-2.2.1.ebuild
new file mode 100644
index 000000000000..b323c3f6c7cb
--- /dev/null
+++ b/dev-util/codespell/codespell-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://github.com/codespell-project/codespell"
+SRC_URI="https://github.com/codespell-project/codespell/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Code licensed under GPL-2
+# Dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ sys-apps/help2man
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # do not depend on pytest-cov
+ sed -e '/addopts/d' -i setup.cfg || die
+}
+
+python_compile_all() {
+ # generate included man page
+ emake ${PN}.1
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+}