summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/catfish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.2.2.ebuild64
-rw-r--r--dev-util/catfish/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
new file mode 100644
index 000000000000..29358509c60c
--- /dev/null
+++ b/dev-util/catfish/Manifest
@@ -0,0 +1 @@
+DIST catfish-1.2.2.tar.bz2 98956 SHA256 0e92844e761207b3d3086c45b26fccf83f0ebced741e1af33d8590779f25eedf SHA512 dad407f1e818b8d537b73e9f832c39ca4f9527b9d636da18493a685b03d2fab56982a11872382fd457b9a1a0ffb33d29ade4aa317561c3b2ee82c96728705e75 WHIRLPOOL 42f379cfffef9c9115ca1ef1b2e25e46da8ceac60778d0fccdb626c1d61567028caf2f497a76fed2b530dd126024b26b9f3248c38bbf185a20576d4a52930484
diff --git a/dev-util/catfish/catfish-1.2.2.ebuild b/dev-util/catfish/catfish-1.2.2.ebuild
new file mode 100644
index 000000000000..5dd31350ac5e
--- /dev/null
+++ b/dev-util/catfish/catfish-1.2.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit eutils gnome2-utils python-single-r1
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="http://launchpad.net/catfish-search http://twotoasts.de/index.php/catfish/"
+SRC_URI="http://launchpad.net/${PN}-search/${PV%.*}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ strip-linguas -i po/
+ if ! [[ -z "${LINGUAS}" ]]; then
+ local lang langs=$(find po/ -name '*.po' | sed -e 's|po/||g;s|.po||g')
+ for lang in $langs; do
+ if ! has ${lang} ${LINGUAS}; then
+ rm po/${lang}.po || die
+ fi
+ done
+ fi
+
+ python_fix_shebang .
+ sed -i -e "s:share/doc/\$(APPNAME):share/doc/${PF}:" Makefile.in.in || die
+}
+
+src_configure() {
+ # not autotools based
+ ./configure --prefix=/usr --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+ python_optimize "${ED}"/usr/share/${PN}
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/dev-util/catfish/metadata.xml b/dev-util/catfish/metadata.xml
new file mode 100644
index 000000000000..c1dcc264f34f
--- /dev/null
+++ b/dev-util/catfish/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="launchpad">catfish-search</remote-id>
+ </upstream>
+</pkgmetadata>