summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-01-28 17:59:41 +0100
committerSam James <sam@gentoo.org>2024-01-30 08:29:18 +0000
commit2ff037509efddad44e3dc112503e43d9aa71bcb4 (patch)
tree1535c577b1b63f453d03f3fab774710e8535b0cc /dev-util/buildbot-wsgi-dashboards
parentdev-util/buildbot-worker: add 3.11.0 (diff)
downloadgentoo-2ff037509efddad44e3dc112503e43d9aa71bcb4.tar.gz
gentoo-2ff037509efddad44e3dc112503e43d9aa71bcb4.tar.bz2
gentoo-2ff037509efddad44e3dc112503e43d9aa71bcb4.zip
dev-util/buildbot-wsgi-dashboards: add 3.11.0
Closes: https://bugs.gentoo.org/920676 Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 5ab5fe72f313..14b1f74413ed 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,2 +1,3 @@
+DIST buildbot-wsgi-dashboards-3.11.0.tar.gz 6224 BLAKE2B 87bd27e64f5cd381a615d53e990c9723c0ebf9ae35a8fe17208a198f960a4496603bbb34394e7fda8ed8ac06f5e6b69b9dc8c813addc062b26b6d8ea6394c2ff SHA512 e361af137240282cc30e3f42214a3a71f9a829fcf409b8d908e6ab80894c1f8e91abeef2b5c9e1c8b75a8a90e1b922866b6598fce9c59649a12a1c5c2b7ed2c7
DIST buildbot-wsgi-dashboards-3.6.1.tar.gz 5584 BLAKE2B f0b82de52022c3a8a0d0747aa4ade67345af177be70a8767d66163fe98ceff63e0b297ba547619de874a66e381b721c48d864361fdb82a818f2450c339d687cc SHA512 7ecd4fd71786258deab1fb1d96b4999ef929df4486d09404cb1bc3d1a7f831c90f8253f5bf0474258ba472ac9e8f960f4c4eb1f7993a0a8070eaa68e3bbbb4e9
DIST buildbot-wsgi-dashboards-3.9.0.tar.gz 6224 BLAKE2B 462dc93c1334ba8daba5eb01b85eb7747a2ce4a9dfc17f5e96f1fd4dc8c5d54d1740d4a041d667cd38e67d1d4e25c44845a90758e3d3a7925f12802d78152ed0 SHA512 fbdf567fe08d83b62ad0b4a5eca35a01567a1bdccd749adced1dad89805c102fdb6d6a35d8d7b07b2b47b9762a411c62a86aaa28c28b370363383a9130091352
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.0.ebuild
new file mode 100644
index 000000000000..046d64a9e087
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"