summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-01-28 17:54:07 +0100
committerSam James <sam@gentoo.org>2024-01-30 08:29:16 +0000
commite59e4409e5dbc3c8f82ffbc024d8602e98562411 (patch)
tree686aef7eeb25225e55a04f02796995b793ea0178 /dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
parentdev-util/buildbot-grid-view: add 3.11.0 (diff)
downloadgentoo-e59e4409e5dbc3c8f82ffbc024d8602e98562411.tar.gz
gentoo-e59e4409e5dbc3c8f82ffbc024d8602e98562411.tar.bz2
gentoo-e59e4409e5dbc3c8f82ffbc024d8602e98562411.zip
dev-util/buildbot-pkg: add 3.11.0
Closes: https://bugs.gentoo.org/920676 Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
new file mode 100644
index 000000000000..35f5e4f31f26
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-pkg/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+RESTRICT="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e "/version/s/=.*$/=\"${PV/_p/.post}\",/" -i setup.py || die
+ distutils-r1_src_prepare
+}