summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-06 18:05:51 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-06 18:54:21 -0600
commit8d7ceed44f148b52fa76b684354bd5141d9360cf (patch)
treed19af960ce85255247a84fd880bea340afb8cd65 /dev-util/astyle
parentdev-python/faulthandler: version bump to 3.0 (diff)
downloadgentoo-8d7ceed44f148b52fa76b684354bd5141d9360cf.tar.gz
gentoo-8d7ceed44f148b52fa76b684354bd5141d9360cf.tar.bz2
gentoo-8d7ceed44f148b52fa76b684354bd5141d9360cf.zip
dev-util/astyle: version bump to 3.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest1
-rw-r--r--dev-util/astyle/astyle-3.1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 7ac39e210696..a5baf6095662 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1 +1,2 @@
DIST astyle_3.0.1_linux.tar.gz 172483 BLAKE2B 4c80491cbcc976aa38ff294014df0dc01b39685eafdac6989bea082b1f61120c3985d14ff6db9f76606bbe8da1aaa344c2e0c9c2999a014f5d54384c0420cf97 SHA512 3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158
+DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
diff --git a/dev-util/astyle/astyle-3.1.ebuild b/dev-util/astyle/astyle-3.1.ebuild
new file mode 100644
index 000000000000..a84f1e30d840
--- /dev/null
+++ b/dev-util/astyle/astyle-3.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ # ../build/clang/Makefile is identical except for CXX line.
+ emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ # ex: libastyle.so.3.0.1
+ dolib.so lib${PN}.so.${PV}.0
+ # ex: libastyle.so.3
+ dosym lib${PN}.so.${PV}.0 /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
+ if use java ; then
+ dolib.so lib${PN}j.so.${PV}
+ dosym lib${PN}j.so.${PV} /usr/$(get_libdir)/lib${PN}j.so.$(get_major_version)
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
+ elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
+ elog "for modern use. Some options that were valid in 2.06 or older are now"
+ elog "deprecated. For more information, consult astyle's release notes at"
+ elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
+ elog
+ elog "${ROOT}usr/share/doc/${P}/html"
+ fi
+}