summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-23 00:47:52 +0000
committerSam James <sam@gentoo.org>2022-11-23 00:47:52 +0000
commit0f3b4b7485a41f2662c0780d21e672ae1bb5348d (patch)
treefd3bd04d1e945bd17e2debb832917f9b742367c4 /dev-tcltk
parentdev-tcltk/tkpng: fix configure w/ clang 16 (diff)
downloadgentoo-0f3b4b7485a41f2662c0780d21e672ae1bb5348d.tar.gz
gentoo-0f3b4b7485a41f2662c0780d21e672ae1bb5348d.tar.bz2
gentoo-0f3b4b7485a41f2662c0780d21e672ae1bb5348d.zip
dev-tcltk/tix: fix -Wimplicit-int
All types ended up being an int so no need to revbump. Doesn't actually full build with Clang 16 though yet. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tix/files/tix-8.4.3-wimplicit-int.patch49
-rw-r--r--dev-tcltk/tix/tix-8.4.3-r2.ebuild7
2 files changed, 53 insertions, 3 deletions
diff --git a/dev-tcltk/tix/files/tix-8.4.3-wimplicit-int.patch b/dev-tcltk/tix/files/tix-8.4.3-wimplicit-int.patch
new file mode 100644
index 000000000000..b97d55c05a77
--- /dev/null
+++ b/dev-tcltk/tix/files/tix-8.4.3-wimplicit-int.patch
@@ -0,0 +1,49 @@
+https://sourceforge.net/p/tix/bugs/112/
+
+Avoid implicit int declarations, a feature removed from C language with C99.
+
+--- a/generic/tixDiImg.c
++++ b/generic/tixDiImg.c
+@@ -352,6 +352,8 @@ Tix_ImageItemDisplay(drawable, iPtr, x, y, width, height, xOffset, yOffset,
+ int y;
+ int width;
+ int height;
++ int xOffset;
++ int yOffset;
+ int flags;
+ {
+ TixImageItem *itPtr = (TixImageItem *)iPtr;
+--- a/generic/tixDiWin.c
++++ b/generic/tixDiWin.c
+@@ -458,6 +458,8 @@ Tix_WindowItemDisplay(drawable, iPtr, x, y, width, height, xOffset, yOffset,
+ int y;
+ int width;
+ int height;
++ int xOffset;
++ int yOffset;
+ int flags;
+ {
+ TixWindowItem *itPtr = (TixWindowItem *)iPtr;
+--- a/generic/tixForm.c
++++ b/generic/tixForm.c
+@@ -150,7 +150,7 @@ static Tcl_HashTable masterInfoHashTable;
+ /*
+ * Have static variables in this module been initialized?
+ */
+-static initialized = 0;
++static int initialized = 0;
+
+ static int ReqSize(tkwin, axis)
+ Tk_Window tkwin;
+--- a/unix/tixUnixMwm.c
++++ b/unix/tixUnixMwm.c
+@@ -768,7 +768,7 @@ GetMwmInfo(interp, tkwin)
+ Tcl_Interp * interp;
+ Tk_Window tkwin;
+ {
+- static inited = 0;
++ static int inited = 0;
+ Tcl_HashEntry *hashPtr;
+ int isNew;
+
+
diff --git a/dev-tcltk/tix/tix-8.4.3-r2.ebuild b/dev-tcltk/tix/tix-8.4.3-r2.ebuild
index e5534f6912ab..52e0231aaf70 100644
--- a/dev-tcltk/tix/tix-8.4.3-r2.ebuild
+++ b/dev-tcltk/tix/tix-8.4.3-r2.ebuild
@@ -11,14 +11,14 @@ SRC_URI="mirror://sourceforge/tix/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
RESTRICT="test"
DEPEND="
- dev-lang/tk:0=
+ dev-lang/tk:=
x11-libs/libX11
x11-libs/libXau
- x11-libs/libXdmcp"
+ x11-libs/libXdmcp
+"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -26,6 +26,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-tcl8.5.patch
"${FILESDIR}"/${P}-tcl8.6.patch
+ "${FILESDIR}"/${P}-wimplicit-int.patch
)
src_prepare() {