summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tcl3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tcl3d')
-rw-r--r--dev-tcltk/tcl3d/Manifest1
-rw-r--r--dev-tcltk/tcl3d/metadata.xml22
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild57
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-tcltk/tcl3d/Manifest b/dev-tcltk/tcl3d/Manifest
new file mode 100644
index 000000000000..a5c60e4e4558
--- /dev/null
+++ b/dev-tcltk/tcl3d/Manifest
@@ -0,0 +1 @@
+DIST tcl3d-src-0.4.0.zip 1501305 SHA256 f98bee3c2ca0189780125b683481949e1499018ee56ad1d21b4e3e594e058496 SHA512 a8a525693bc45e9fb9e2167e2121d300ff60534f2bced33bb068a1075cfd8e8281dd97bd7fb432b9d6a95cdb37fc3da03c82dd1ee20e368fb8ac249ea54c30a5 WHIRLPOOL cbc1982df7a28b93249ff7877d0376b06b64261bb33f3df8c64b2c80600684529605b9eeff6f593c2e9f7c64c253066b226f0a0dae9cee21bec980f6782c7777
diff --git a/dev-tcltk/tcl3d/metadata.xml b/dev-tcltk/tcl3d/metadata.xml
new file mode 100644
index 000000000000..8791d02088e4
--- /dev/null
+++ b/dev-tcltk/tcl3d/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tcltk</herd>
+<longdescription>
+Tcl3D offers the 3D functionality of OpenGL and other 3D libraries at the Tcl scripting level.
+The Tcl3D package currently consists of the following modules:
+
+Tcl3D core module
+tcl3dOgl Enhanced Togl widget, a Tk widget for displaying OpenGL content.
+ Wrapper for core OpenGL functionality (GL Version 3.0, GLU Version 1.2) and OpenGL extensions.
+ Tcl3D utility library: Math functions, standard shapes, stop watch, demo support.
+
+Tcl3D optional modules
+tcl3dCg Wrapper for NVidia's Cg shading language. *
+tcl3dSDL Wrapper for the Simple DirectMedia Library.
+tcl3dFTGL Wrapper for the OpenGL Font Rendering Library.
+tcl3dGl2ps Wrapper for the OpenGL To Postscript library. *
+tcl3dOde Wrapper for the Open Dynamics Engine.
+tcl3dGauges Tcl3D package for displaying gauges.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild b/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild
new file mode 100644
index 000000000000..d750c1bb212f
--- /dev/null
+++ b/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Tcl bindings to OpenGL and other 3D libraries"
+HOMEPAGE="http://www.tcl3d.org"
+SRC_URI="http://www.tcl3d.org/download/${P}.distrib/${PN}-src-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-games/ode
+ dev-lang/tk:0=
+ dev-lang/tcl:0=
+ media-libs/libsdl
+ media-libs/ftgl
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.19"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ TCL_VERSION=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
+ einfo "Configuring for Tcl ${TCL_VERSION[0]}.${TCL_VERSION[1]}"
+ sed -i \
+ -e 's:^\(TCLMAJOR\) *=\(.*\)$:\1 = '${TCL_VERSION[0]}':' \
+ -e 's:^\(TCLMINOR\) *=\(.*\)$:\1 = '${TCL_VERSION[1]}':' \
+ config_Linux* || die
+
+ # fix libSDL link
+ sed -i \
+ -e 's:-lSDL-1\.2:-lSDL:g' \
+ tcl3dSDL/Makefile || die
+}
+
+src_compile() {
+ append-flags -mieee-fp -ffloat-store -fPIC
+ use debug || append-flags -DNDEBUG
+
+ emake \
+ INSTDIR="/usr" OPT="${CFLAGS}" CC="$(tc-getCC) -c" \
+ CXX="$(tc-getCXX) -c" LD="$(tc-getLD)" \
+ WRAP_FTGL=1 WRAP_SDL=1 WRAP_GL2PS=0 WRAP_ODE=1
+}
+
+src_install() {
+ emake INSTDIR="${D}/usr" DESTDIR="${D}" INSTLIB="${D}/usr$(get_libdir)" install
+}