summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-26 23:30:47 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:34 +0200
commit3d47cb716f05b8bbfefcf41b146cc0ea5ac974ee (patch)
tree68dba3f53b22fb87bc07f90f5acf56da410550d9 /dev-scheme
parentdev-scheme/guile-dbd-sqlite3: add 2.1.9 + switch to new guile mechanism (diff)
downloadgentoo-3d47cb716f05b8bbfefcf41b146cc0ea5ac974ee.tar.gz
gentoo-3d47cb716f05b8bbfefcf41b146cc0ea5ac974ee.tar.bz2
gentoo-3d47cb716f05b8bbfefcf41b146cc0ea5ac974ee.zip
dev-scheme/guile-gcrypt: switch to new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild
new file mode 100644
index 000000000000..bfe2d620c882
--- /dev/null
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r100.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile
+
+DESCRIPTION="Guile bindings of libgcrypt"
+HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://notabug.org/cwebber/${PN}.git"
+else
+ SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+RDEPEND="
+ ${GUILE_DEPS}
+ dev-libs/libgcrypt:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ guile_src_prepare
+ eautoreconf
+}