summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-09 08:17:35 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-09 08:39:54 +0100
commite1694f92f86e894eb07621754b95a3437a659e90 (patch)
tree81d2517c94e4ffabcd2dbd162f9295612a98db05 /dev-ruby
parentrust.eclass: add missing `/` in `get_rust_path` for `binary` builds. (diff)
downloadgentoo-e1694f92f86e894eb07621754b95a3437a659e90.tar.gz
gentoo-e1694f92f86e894eb07621754b95a3437a659e90.tar.bz2
gentoo-e1694f92f86e894eb07621754b95a3437a659e90.zip
dev-ruby/ostruct: add 0.6.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ostruct/Manifest1
-rw-r--r--dev-ruby/ostruct/ostruct-0.6.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ostruct/Manifest b/dev-ruby/ostruct/Manifest
index 1870ea23e1a9..1db968e24410 100644
--- a/dev-ruby/ostruct/Manifest
+++ b/dev-ruby/ostruct/Manifest
@@ -1 +1,2 @@
DIST ostruct-0.6.0.tar.gz 10757 BLAKE2B 68742978efc348d28361716a18a4b9a5e23270e37a104aa3e620d3a751182f22003db467c2424025c831315a2ddb7bf4f9bb4f76b43ab612f64eb56875b55860 SHA512 34afddbc0e881432fcd143669ad182d3ddef7b2245d1429466ff893f8a419482b3fc577eea331d3edfecbe2ac831e9b3b1e5d0baa66de5528fe312afb4e2b087
+DIST ostruct-0.6.1.tar.gz 12181 BLAKE2B df7864c739b4a8beb601e8a8232c07393eb29f519660261f9cccde9a3a0164c6a14eaf3f0c9c9a098cfbafc110ea2ab1ddd19c05de98f1f67c5866eaf3e61cf6 SHA512 34c141dde253bed7b0637b353bc55fd052c708e5e1558e1a348e43e1aa633f0a0c7806231e7e2931b400a43c3dfde533ae5ac3ed20291ff73d1296121e0517b3
diff --git a/dev-ruby/ostruct/ostruct-0.6.1.ebuild b/dev-ruby/ostruct/ostruct-0.6.1.ebuild
new file mode 100644
index 000000000000..2f08ed1e2061
--- /dev/null
+++ b/dev-ruby/ostruct/ostruct-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ostruct.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Class to build custom data structures, similar to a Hash"
+HOMEPAGE="https://github.com/ruby/ostruct"
+SRC_URI="https://github.com/ruby/ostruct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_depend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"ostruct.gemspec"/' \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}