summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-28 08:41:56 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-28 08:42:29 +0200
commitda31f00fd30bf3101b967c2e8d5f8eddb4d45928 (patch)
treea841d6658a52d166ec1cb7508011663dbd279a98 /dev-ruby
parentdev-ruby/maxitest: add 5.4.0 (diff)
downloadgentoo-da31f00fd30bf3101b967c2e8d5f8eddb4d45928.tar.gz
gentoo-da31f00fd30bf3101b967c2e8d5f8eddb4d45928.tar.bz2
gentoo-da31f00fd30bf3101b967c2e8d5f8eddb4d45928.zip
dev-ruby/propshaft: add 0.8.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/propshaft/Manifest1
-rw-r--r--dev-ruby/propshaft/propshaft-0.8.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/Manifest b/dev-ruby/propshaft/Manifest
index fb3b5965f4d2..98444331380f 100644
--- a/dev-ruby/propshaft/Manifest
+++ b/dev-ruby/propshaft/Manifest
@@ -1 +1,2 @@
DIST propshaft-0.7.0-git.tgz 247111 BLAKE2B aecf4dcab9b57f1933e8f7066f4b229348cf60e4104cc82e14edb945e797a263012fe5b7b65de8ff0165e652256a0bd8fba24af8f08d8e9391050e36e56d5f31 SHA512 3d6dba7a3b5b522f3e4a9f43dc6b9981fbb475374be0b90c8abb2f19c587d025b58876ddb6a9e1b9992e3f357a96b50b6138173d10b8ae131e9457309b8cc0c9
+DIST propshaft-0.8.0-git.tgz 247518 BLAKE2B fe57104a1abd683d74a3166931256f2cdc8e942fffe80c286acfc6db6fa105810bc929f03dd959a660835f030acb580dbd18e7b20f16cfb168b0953731bb2f90 SHA512 3a40355063edb912107ec27ac43ba76746bbd04da04096a4480b43f6fd103bfaec53957d1bbc2bf3d0e08237d965af4d3bf8067b558c4e417ffb506a84f1abff
diff --git a/dev-ruby/propshaft/propshaft-0.8.0.ebuild b/dev-ruby/propshaft/propshaft-0.8.0.ebuild
new file mode 100644
index 000000000000..9f12429acd24
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}