summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:09:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:09:55 -0500
commit8264bd61a5e353dd61e861a345f6686ea6635f7e (patch)
treef42512cf0466a24115b05257bbd7057ad5777b95 /dev-ruby
parentapp-admin/puppetserver: 7.9.0 bump (diff)
downloadgentoo-8264bd61a5e353dd61e861a345f6686ea6635f7e.tar.gz
gentoo-8264bd61a5e353dd61e861a345f6686ea6635f7e.tar.bz2
gentoo-8264bd61a5e353dd61e861a345f6686ea6635f7e.zip
dev-ruby/puppetdb-termini: 7.11.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 9d2e2cff0662..a4577c1289db 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1 +1,2 @@
DIST puppetdb-termini_7.10.1-1stretch_all.deb 22156 BLAKE2B 52b1060fcf177b37229303ef93f90424f2b6b29eadf8041aa733d20f6b417c16e163891c44bc6f7845957ced10db132c705d6d6031041abace2f8f66f3d64964 SHA512 b273ac57558c9255d342010d9f3ada729596582311b3bbe658bf1505bd457041d0f5948c35c37bad585c931a66a66dcadcc71960de695c126715ef53d08295c5
+DIST puppetdb-termini_7.11.0-1stretch_all.deb 22662 BLAKE2B b5b0d19829d6570076b4861bef85342d7ac925250fec6a892a7106319585851800ebdf9e947d8ef18d764d1abccef104acce82820a73511f9f92468e9c5c0998 SHA512 0450787b4411192214f05a8ca87b683a0792910a3aed3ec1680a2810e1566f0817b424d6ba3bdd95803f3ad6fb3f98ef8efb648064318dbcae39c23072d1bd85
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
new file mode 100644
index 000000000000..68f1eaa1a4b6
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}