summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-22 10:47:32 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-23 07:04:46 +0200
commitbc345797a61d2532e1f383f5c6a7de35fa6bde58 (patch)
tree9bec3b4edc7e7eb34bfd60d2110942d6ee69d6e2 /dev-ruby/webmock
parentdev-ruby/thor: avoid failing test (diff)
downloadgentoo-bc345797a61d2532e1f383f5c6a7de35fa6bde58.tar.gz
gentoo-bc345797a61d2532e1f383f5c6a7de35fa6bde58.tar.bz2
gentoo-bc345797a61d2532e1f383f5c6a7de35fa6bde58.zip
dev-ruby/webmock: drop httpclient test dependency
dev-ruby/httpclient is no longer maintained and has various test failures. Drop the tests for it in webmock to make removal easier. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/webmock')
-rw-r--r--dev-ruby/webmock/webmock-3.14.0.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-ruby/webmock/webmock-3.14.0.ebuild b/dev-ruby/webmock/webmock-3.14.0.ebuild
index 14e65474461e..01c54fdd73ab 100644
--- a/dev-ruby/webmock/webmock-3.14.0.ebuild
+++ b/dev-ruby/webmock/webmock-3.14.0.ebuild
@@ -30,7 +30,6 @@ ruby_add_bdepend "test? (
dev-ruby/rspec:3
>=dev-ruby/test-unit-3.0.0
dev-ruby/rack
- >=dev-ruby/httpclient-2.8.0
)"
all_ruby_prepare() {
@@ -43,19 +42,14 @@ all_ruby_prepare() {
# There is now optional support for curb and typhoeus which we don't
# have in Gentoo yet. em_http_request is available in Gentoo but its
# version is too old. patron's latest version is not compatible.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
+ # httpclient is no longer maintained and has various test failures.
+ sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
# Drop tests for dev-ruby/http for now since this package only works with ruby26
sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
rm -f spec/acceptance/http_rb/* || die
- # Avoid httpclient specs that require network access, most likely
- # because mocking does not fully work.
- sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
- -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
- spec/acceptance/httpclient/httpclient_spec.rb
-
# Avoid specs that require network access
sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
}