summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-13 15:08:48 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-13 15:08:57 +0200
commit13f330603c88d1bc0ec155a33bc221eb40888bbc (patch)
treedba48a9783414f8084f40dc41ce22f6cc41bb8a2 /dev-ruby/ruby-progressbar
parentdev-ruby/rspectacular: add ruby27 (diff)
downloadgentoo-13f330603c88d1bc0ec155a33bc221eb40888bbc.tar.gz
gentoo-13f330603c88d1bc0ec155a33bc221eb40888bbc.tar.bz2
gentoo-13f330603c88d1bc0ec155a33bc221eb40888bbc.zip
dev-ruby/ruby-progressbar: add ruby27
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1-r1.ebuild
new file mode 100644
index 000000000000..b6ec3ad17681
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+ # Avoid ruby24 syntax for an unneeded check
+ sed -i -e '/^return/ s:^:#:' spec/ruby-progressbar/refinements/enumerator_spec.rb || die
+}