summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-22 11:06:13 +0000
committerSam James <sam@gentoo.org>2023-03-23 06:51:30 +0000
commitb051a9681a982940ed209333598dae1becb6e889 (patch)
tree7f80b95d374181acdedea8f036c86dbfa07deb07 /dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
parentdev-ruby/fuubar: update upstream metadata (diff)
downloadgentoo-b051a9681a982940ed209333598dae1becb6e889.tar.gz
gentoo-b051a9681a982940ed209333598dae1becb6e889.tar.bz2
gentoo-b051a9681a982940ed209333598dae1becb6e889.zip
dev-ruby/ruby-progressbar: add 1.13.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
new file mode 100644
index 000000000000..b77912c368ba
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}