summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rrdtool-bindings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rrdtool-bindings')
-rw-r--r--dev-ruby/rrdtool-bindings/Manifest3
-rw-r--r--dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch70
-rw-r--r--dev-ruby/rrdtool-bindings/metadata.xml9
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild58
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8.ebuild47
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild58
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.5.3.ebuild64
7 files changed, 309 insertions, 0 deletions
diff --git a/dev-ruby/rrdtool-bindings/Manifest b/dev-ruby/rrdtool-bindings/Manifest
new file mode 100644
index 000000000000..4296af6a11c2
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/Manifest
@@ -0,0 +1,3 @@
+DIST rrdtool-1.4.8.tar.gz 1379482 SHA256 de95b9f5aa488b0683600aad5a07c316f8d98cbe8d00aa0a1c87e2b2ef89f3d6 SHA512 c525978829508e1db393092c948d8db910554f42e1221acc4064a8f546ceac5d68943f603c6f0ef0e6510bbe5f606cfe6862672145ea1b630cd2b7fd07fa805b WHIRLPOOL f3926aed715a80c8d8287b057c39bbe614d81ebf9f24d1e285a9a438594d5c4c66b59934cc7c6be0550f0f729f319b01a46efc32ccf0b412563c43cf74a21564
+DIST rrdtool-1.4.9.tar.gz 1385640 SHA256 3e2826e0d60aaf85313da35b3c0d3a926748fe482b4ada766a325a83b60125cc SHA512 938d6a10c750cbc1e368020fc2408644bc10f6e1d9316f3117df406beef16d7d5fca2fc6fa2bdb6b1ed3e49aa872d58f1f66d1ccee9fe73483c6a5e483c33d4a WHIRLPOOL bc5fb01aef18feb89bb801a2f7fa8c2002b8f8a40e8038355e7edda8a729f354a639c864c01a1ddc7a66d19c8911d75f4f202008bec994d521a209dc6579fe10
+DIST rrdtool-1.5.3.tar.gz 2158011 SHA256 79e7b2f5cf74843e89fe4d08925f955268fd21736cbea03e54ae83320fc6129f SHA512 51e0dbca582acde1a0e77a8fcc4ffa2389b5467b5eb2443a6c9e38851459b7aa9bc08a8d5fd44f69c72e3cdb46be64a2baa66c69ca86a4cda8a061120fa14afb WHIRLPOOL 8738a499699423bd7c2536ca8d8b57db386b190fdeea47328c126aa70fae8d604ab1ab18253567a8426fe73e3fb9ab17ba8c40563841015da96451dcb4435dd7
diff --git a/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch b/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch
new file mode 100644
index 000000000000..8c26ce48cfb3
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch
@@ -0,0 +1,70 @@
+--- a/bindings/ruby/main.c
++++ b/bindings/ruby/main.c
+@@ -216,13 +216,14 @@
+ return rb_rrd_infocall(rrd_update_v, args);
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_graphv(
+ VALUE self,
+ VALUE args)
+ {
+ return rb_rrd_infocall(rrd_graph_v, args);
+ }
+-
++#endif /* HAVE_RRD_GRAPH */
+
+ /* Other Calls */
+
+@@ -273,6 +274,7 @@
+ return result;
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_graph(
+ VALUE self,
+ VALUE args)
+@@ -302,7 +304,7 @@
+ rb_ary_store(result, 2, INT2FIX(ysize));
+ return result;
+ }
+-
++#endif /* HAVE_RRD_GRAPH */
+
+ VALUE rb_rrd_last(
+ VALUE self,
+@@ -320,6 +322,7 @@
+ return rb_funcall(rb_cTime, rb_intern("at"), 1, UINT2NUM(last));
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_xport(
+ VALUE self,
+ VALUE args)
+@@ -367,6 +370,7 @@
+ rb_ary_store(result, 5, rdata);
+ return result;
+ }
++#endif /* HAVE_RRD_GRAPH */
+
+ void Init_RRD(
+ )
+@@ -377,7 +381,9 @@
+ rb_define_module_function(mRRD, "create", rb_rrd_create, -2);
+ rb_define_module_function(mRRD, "dump", rb_rrd_dump, -2);
+ rb_define_module_function(mRRD, "fetch", rb_rrd_fetch, -2);
++#ifdef HAVE_RRD_GRAPH
+ rb_define_module_function(mRRD, "graph", rb_rrd_graph, -2);
++#endif /* HAVE_RRD_GRAPH */
+ rb_define_module_function(mRRD, "last", rb_rrd_last, -2);
+ rb_define_module_function(mRRD, "resize", rb_rrd_resize, -2);
+ rb_define_module_function(mRRD, "restore", rb_rrd_restore, -2);
+@@ -386,6 +392,8 @@
+ rb_define_module_function(mRRD, "flushcached", rb_rrd_flushcached, -2);
+ rb_define_module_function(mRRD, "info", rb_rrd_info, -2);
+ rb_define_module_function(mRRD, "updatev", rb_rrd_updatev, -2);
++#ifdef HAVE_RRD_GRAPH
+ rb_define_module_function(mRRD, "graphv", rb_rrd_graphv, -2);
+ rb_define_module_function(mRRD, "xport", rb_rrd_xport, -2);
++#endif /* HAVE_RRD_GRAPH */
+ }
diff --git a/dev-ruby/rrdtool-bindings/metadata.xml b/dev-ruby/rrdtool-bindings/metadata.xml
new file mode 100644
index 000000000000..8e9d89ef099b
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <herd>netmon</herd>
+<use>
+<flag name='graph'>Enable support for graphing functions</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild
new file mode 100644
index 000000000000..4c890d8e737e
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${P}-graph-ruby.patch
+)
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH '')" || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8.ebuild
new file mode 100644
index 000000000000..a40be385ffb3
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="${RDEPEND} net-analyzer/rrdtool[graph] !!<net-analyzer/rrdtool-1.4.8-r1"
+DEPEND="${DEPEND} net-analyzer/rrdtool[graph]"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild
new file mode 100644
index 000000000000..4f5b74c26f30
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
+)
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH '')" || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.5.3.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.5.3.ebuild
new file mode 100644
index 000000000000..9edbf7a237a1
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.5.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+MY_P=${MY_P/_/-}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
+)
+
+each_ruby_configure() {
+ rm ../../src/rrd_config.h || die
+ touch ../../src/rrd_config.h || die
+
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
+}
+
+each_ruby_compile() {
+ emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
+}
+
+each_ruby_test() {
+ if use graph; then
+ ${RUBY} -I. test.rb || die
+ fi
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}