summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-11-24 07:17:46 +0100
committerHans de Graaff <graaff@gentoo.org>2019-11-24 07:17:46 +0100
commit9737e158c184ea85f887d01cf496118bcc1e6f40 (patch)
tree1fe7cc329195bbd9f0d31cbae72e3711d210a6e2 /dev-ruby/rqrcode_core
parentsci-libs/lapack: arm64 stable (bug #698756) (diff)
downloadgentoo-9737e158c184ea85f887d01cf496118bcc1e6f40.tar.gz
gentoo-9737e158c184ea85f887d01cf496118bcc1e6f40.tar.bz2
gentoo-9737e158c184ea85f887d01cf496118bcc1e6f40.zip
dev-ruby/rqrcode_core: initial import of 0.1.0
Split off from dev-ruby/rqrcode Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rqrcode_core')
-rw-r--r--dev-ruby/rqrcode_core/Manifest1
-rw-r--r--dev-ruby/rqrcode_core/metadata.xml8
-rw-r--r--dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild28
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode_core/Manifest b/dev-ruby/rqrcode_core/Manifest
new file mode 100644
index 000000000000..43369a05c110
--- /dev/null
+++ b/dev-ruby/rqrcode_core/Manifest
@@ -0,0 +1 @@
+DIST rqrcode_core-0.1.0.tar.gz 20241 BLAKE2B 1d6f97cd8e1188c0a3ba0246d2102a901ac64fb0bb08317479f9061d3273ea49388e4a6ea02c8de6b54f8e928aefab62fe8b0dca8ba9f7ed31625cf84965df4b SHA512 30ba73f45d69360b0efbf543a774c709a4397bd8f726f4edeaa830397187cd5c7535ac5816d65cea00f356f7111f69629f03fa508b7a7fc91d5618c4cebd8167
diff --git a/dev-ruby/rqrcode_core/metadata.xml b/dev-ruby/rqrcode_core/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/rqrcode_core/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild b/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild
new file mode 100644
index 000000000000..58979b3170b3
--- /dev/null
+++ b/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode_core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://github.com/whomwah/rqrcode_core/"
+SRC_URI="https://github.com/whomwah/rqrcode_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}