summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-04 07:34:58 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-04 07:41:07 +0200
commit139a6617804b9fabca415e0163b940aa80c0fe2e (patch)
treec312905e084b366a1d3fc8c05491307b43cb42ff /dev-ruby/radius
parentnet-analyzer/sslscan: add 2.0.13 (diff)
downloadgentoo-139a6617804b9fabca415e0163b940aa80c0fe2e.tar.gz
gentoo-139a6617804b9fabca415e0163b940aa80c0fe2e.tar.bz2
gentoo-139a6617804b9fabca415e0163b940aa80c0fe2e.zip
dev-ruby/radius: update EAPI 6 -> 8, add ruby30
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/radius')
-rw-r--r--dev-ruby/radius/radius-0.7.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/radius/radius-0.7.5-r1.ebuild b/dev-ruby/radius/radius-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..8fd66a96aa1d
--- /dev/null
+++ b/dev-ruby/radius/radius-0.7.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG QUICKSTART.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Powerful tag-based template system"
+HOMEPAGE="https://github.com/jlong/radius"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/kramdown )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/d" -e "/coveralls/d" test/test_helper.rb || die
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}