summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-07 09:21:23 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-08 08:49:40 +0100
commitc12c6719d9c9d7981c778d87153fb64ef624e8f7 (patch)
tree3dd4407232d566a3389634eae5258820756d0c65 /dev-ruby/rack-protection
parentdev-ruby/sus: add 0.16.0 (diff)
downloadgentoo-c12c6719d9c9d7981c778d87153fb64ef624e8f7.tar.gz
gentoo-c12c6719d9c9d7981c778d87153fb64ef624e8f7.tar.bz2
gentoo-c12c6719d9c9d7981c778d87153fb64ef624e8f7.zip
dev-ruby/rack-protection: add 3.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.0.5.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index a67be12c4287..01de54161898 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -5,3 +5,4 @@ DIST rack-protection-2.2.3.gem 17920 BLAKE2B 7a66cf4d5de68acd3ef4c7db2485657ce22
DIST rack-protection-3.0.1.gem 20480 BLAKE2B 102fff6298dbbb766313687b6f3653c60d055c654922e108c0e5eab1364858adf83a800c66f0800ef8a48997884e4b0c16ad1a70c2d00d657fdbcdb929c18bbc SHA512 730cb4fa67e86ee79043e706c4a011f1f4fad8902d27ed25a14e03c7acf7644db9e8685bb6248d9511d32d55a1f13eb548cd9471958b69bf88c4c371fcc1a8df
DIST rack-protection-3.0.2.gem 20480 BLAKE2B 95c951c6995ac4e69bb6aca85ff0c8a86793466db84e149ef6d287fb479fe49bc3708d0bc71ca656c4bb79b069d3b01139fab04756bc68051eda90db29f506a4 SHA512 54603e8ba22f1b359e5ffe82a3ee99a31a26e5dedd1e46edd4591ca416a1f241dc37ce2b6da25262a9cf9027b0e8687bd23c6dcbea0197131ca33088cbfd0280
DIST rack-protection-3.0.4.gem 20480 BLAKE2B a71d86a123cdf392632c3193cccf8fc5635ca076039eecc40fd0aa050624e909d63c578727ca1e4bf13736fb844b8d3114ce34a6729b57b600715cab7ec25c1f SHA512 b898c66dcac38219c43b1a6ce3a2952ca35e44f81b604f00dbff43938b5493df4c9a654ae221f01675f8f4b8aaf90f31b435a648f46f70789ac78a0c4a0c4f12
+DIST rack-protection-3.0.5.gem 20480 BLAKE2B 1fa11760c6ddac58234ffe2e6d783c985e29b5e2bd10ea21b0782f7824b5930351c8e32c9401b6276ef028adcd8b25ca4458333d8008a554c413f54315ff8809 SHA512 4ed0ee9e8fe08532ff7f2905251af110f3fff0e419da5be50ae3e5a90906e43c39cf8edc219fcfe3e27a72591500c040afcc9552da875773375b170fb91aa9ff
diff --git a/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild b/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
new file mode 100644
index 000000000000..c1fe98e42fca
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"