summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 18:17:55 +0100
committerSam James <sam@gentoo.org>2023-04-07 19:09:44 +0100
commite88a7489ef2ec88796635a78c572f45c8b5e026f (patch)
tree955e6fa14e25c794452a116474eab1abc5e836b6 /dev-ruby/actionmailer
parentdev-ruby/actiontext: enable ruby32 for 7.0.x (diff)
downloadgentoo-e88a7489ef2ec88796635a78c572f45c8b5e026f.tar.gz
gentoo-e88a7489ef2ec88796635a78c572f45c8b5e026f.tar.bz2
gentoo-e88a7489ef2ec88796635a78c572f45c8b5e026f.zip
dev-ruby/actionmailer: enable ruby32 for 7.0.x
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/actionmailer-7.0.4.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-7.0.4.3-r1.ebuild b/dev-ruby/actionmailer/actionmailer-7.0.4.3-r1.ebuild
new file mode 100644
index 000000000000..3d96f26e8785
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-7.0.4.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
+ dev-ruby/rails-dom-testing:2"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}