summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-01 13:44:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:54 +0100
commit63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f (patch)
treef8946cf8610f6fd36a9f4f460341dbdf160c415c /dev-ros/test_rospy/test_rospy-1.12.6.ebuild
parentdev-ros/test_rosparam: Bump to 1.12.6. (diff)
downloadgentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.tar.gz
gentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.tar.bz2
gentoo-63c34af6e95e4ca1b7ea4245cc6935e6c0e7989f.zip
dev-ros/test_rospy: Bump to 1.12.6.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.12.6.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.12.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.12.6.ebuild b/dev-ros/test_rospy/test_rospy-1.12.6.ebuild
new file mode 100644
index 000000000000..48cb395c90ff
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.12.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"