summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:51:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commite6017de334d29c6f918734361b8ecace6ce4ec59 (patch)
tree51cee378a4f22f8a49705aec43411e14da3eacf4 /dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild
parentdev-ros/test_rosmaster: Bump to 1.12.1. (diff)
downloadgentoo-e6017de334d29c6f918734361b8ecace6ce4ec59.tar.gz
gentoo-e6017de334d29c6f918734361b8ecace6ce4ec59.tar.bz2
gentoo-e6017de334d29c6f918734361b8ecace6ce4ec59.zip
dev-ros/test_rosparam: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild b/dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"