summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-14 10:01:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-14 10:01:52 +0200
commitdd9d568005ce5278c8e63378bb505d796bd73c58 (patch)
treefdf06982f66b112bcf1d2f620d34cd813eb67aa0 /dev-ros/ros_environment/ros_environment-1.3.2.ebuild
parentsys-kernel/pf-sources: remove old (diff)
downloadgentoo-dd9d568005ce5278c8e63378bb505d796bd73c58.tar.gz
gentoo-dd9d568005ce5278c8e63378bb505d796bd73c58.tar.bz2
gentoo-dd9d568005ce5278c8e63378bb505d796bd73c58.zip
dev-ros/ros_environment: bump to 1.3.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ros_environment/ros_environment-1.3.2.ebuild')
-rw-r--r--dev-ros/ros_environment/ros_environment-1.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/ros_environment/ros_environment-1.3.2.ebuild b/dev-ros/ros_environment/ros_environment-1.3.2.ebuild
new file mode 100644
index 000000000000..9b7f339511b4
--- /dev/null
+++ b/dev-ros/ros_environment/ros_environment-1.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_environment"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS environment variables"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!!<dev-ros/roslib-1.14.3"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkinprefixpath.patch" )
+
+src_configure() {
+ export ROS_DISTRO="Gentoo"
+ export ROS_DISTRO_OVERRIDE="Gentoo"
+ ros-catkin_src_configure
+}