summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:46:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:52:23 +0200
commit3127ad231f7ecb77d4fbbcbcaa334604179103de (patch)
treea0540e18957b05aeef219346ef3a24d85f19fbe1 /dev-ros/pcl_ros
parentdev-ros/pcl_conversions: Initial import. Ebuild by me. (diff)
downloadgentoo-3127ad231f7ecb77d4fbbcbcaa334604179103de.tar.gz
gentoo-3127ad231f7ecb77d4fbbcbcaa334604179103de.tar.bz2
gentoo-3127ad231f7ecb77d4fbbcbcaa334604179103de.zip
dev-ros/pcl_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pcl_ros')
-rw-r--r--dev-ros/pcl_ros/Manifest1
-rw-r--r--dev-ros/pcl_ros/metadata.xml5
-rw-r--r--dev-ros/pcl_ros/pcl_ros-1.3.0.ebuild37
-rw-r--r--dev-ros/pcl_ros/pcl_ros-9999.ebuild37
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-ros/pcl_ros/Manifest b/dev-ros/pcl_ros/Manifest
new file mode 100644
index 000000000000..112207c94cfd
--- /dev/null
+++ b/dev-ros/pcl_ros/Manifest
@@ -0,0 +1 @@
+DIST perception_pcl-1.3.0.tar.gz 66060 SHA256 c9b01170ca92240e81113ddd880505f54a08084b67edfe450363499a828b6586 SHA512 203fcc2c1d71bfd6890c4e5664b29404bea666f277eee88d4725766bc21fb7aac3aced467be2f3352e3c172a7175ab8c4124d5652dad03d6a7b661748ec94175 WHIRLPOOL 7e18df41d3f61d1c6f7fa29d3933d1deeaadeb493416ab128df7c6ea9578074771b069c047ad6f71cb46202e4b5e5f6bdcbfbe72519450aeb4a5ab1547378a00
diff --git a/dev-ros/pcl_ros/metadata.xml b/dev-ros/pcl_ros/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/pcl_ros/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pcl_ros/pcl_ros-1.3.0.ebuild b/dev-ros/pcl_ros/pcl_ros-1.3.0.ebuild
new file mode 100644
index 000000000000..9894bf31aa95
--- /dev/null
+++ b/dev-ros/pcl_ros/pcl_ros-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosbag
+ dev-ros/rosconsole
+ dev-ros/roslib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ >=dev-cpp/eigen-3.2.5:3
+ dev-ros/pluginlib
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-ros/nodelet_topic_tools
+ sci-libs/pcl[qhull]
+ dev-ros/pcl_conversions
+ dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pcl_ros/pcl_ros-9999.ebuild b/dev-ros/pcl_ros/pcl_ros-9999.ebuild
new file mode 100644
index 000000000000..9894bf31aa95
--- /dev/null
+++ b/dev-ros/pcl_ros/pcl_ros-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosbag
+ dev-ros/rosconsole
+ dev-ros/roslib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ >=dev-cpp/eigen-3.2.5:3
+ dev-ros/pluginlib
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-ros/nodelet_topic_tools
+ sci-libs/pcl[qhull]
+ dev-ros/pcl_conversions
+ dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"