summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-11 20:26:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-11 20:27:03 +0200
commit260ad8be66f632eac511575207b285a5f591bc26 (patch)
treeaee1d586f4059544db98085ea4b1cfe10a2c20f1 /dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
parentdev-ros/joint_state_publisher: update uri, fix test deps (diff)
downloadgentoo-260ad8be66f632eac511575207b285a5f591bc26.tar.gz
gentoo-260ad8be66f632eac511575207b285a5f591bc26.tar.bz2
gentoo-260ad8be66f632eac511575207b285a5f591bc26.zip
dev-ros/joint_state_publisher: bump to 1.12.13
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
new file mode 100644
index 000000000000..5f4325158a53
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"