summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 22:00:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-09 23:36:28 +0200
commit56acf9bac388533631838ff019e20eb41af0bbe0 (patch)
treec07a708b057f14c3743b759772c8fb0d82704201 /dev-qt/qtwayland
parentqt5-build.eclass: Drop obsolete in-source build workaround for >=5.14.2 (diff)
downloadgentoo-56acf9bac388533631838ff019e20eb41af0bbe0.tar.gz
gentoo-56acf9bac388533631838ff019e20eb41af0bbe0.tar.bz2
gentoo-56acf9bac388533631838ff019e20eb41af0bbe0.zip
dev-qt: Add Qt 5.14.2
Closes: https://bugs.gentoo.org/669994 Closes: https://bugs.gentoo.org/710866 Closes: https://bugs.gentoo.org/713722 Closes: https://bugs.gentoo.org/716754 Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.14.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index f3741d0e9109..112eeb88432b 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-everywhere-src-5.13.2.tar.xz 495536 BLAKE2B eb4352d76caba9ff1d217950b8be40edee1b963a085ca129938ade0d3a68569856bc1a745951d3731c81182b341704568a5036551693cad5926a239587dd506b SHA512 5eb895c2ef8e2e72b71fed027f760913bf754da213e488a6103d9034170a6333f034b3488115a87a5a4e90761425487b9a8ab8e84a68e2e614c159d747408d53
DIST qtwayland-everywhere-src-5.14.1.tar.xz 544744 BLAKE2B cc74e6ac4519484713795169a91f18ed2535684bf604d12ab900a0fb2502d30c1fa4fbdc5899c4a32505e8f4b2be142d3b16540b6797c1624deac097d45ea41d SHA512 6cdfb527ce8160b562343bfb3959dfcd8ccc91a50817756547f4a0559b77372bee7587bc2e4e658e15b58ecb52c6eb0ef2193e30a285d13c4192bb03a1149cfc
+DIST qtwayland-everywhere-src-5.14.2.tar.xz 544532 BLAKE2B 13cf07116737ec2fd301f51f517cbc062fdd42b800d6d2739193f3570f1a9552e66e9909de15c22cc530d5284c3be9ff24915ce4b36f529ec6c22faeb0edff58 SHA512 0f396cabace17f099c2f2c0be54317006dc00c5f4be08cd79a4fa4fdc94362f63cc6ce9decc7feb63f566dd2ea52d562257e4bb23332557054418fc16dc7e899
diff --git a/dev-qt/qtwayland/qtwayland-5.14.2.ebuild b/dev-qt/qtwayland/qtwayland-5.14.2.ebuild
new file mode 100644
index 000000000000..00131b6ecb13
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.14.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ ~dev-qt/qtgui-${PV}[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use X || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}