summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 09:44:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:43:22 +0300
commite96ed9874a6efce9378a8d01b0eee53663a0ab6c (patch)
treeb98f0a9e16f1e279e8f5c37d3fa98bfac8337c74 /dev-python
parentdev-java/log4j-over-slf4j: new package, add 2.0.3 (diff)
downloadgentoo-e96ed9874a6efce9378a8d01b0eee53663a0ab6c.tar.gz
gentoo-e96ed9874a6efce9378a8d01b0eee53663a0ab6c.tar.bz2
gentoo-e96ed9874a6efce9378a8d01b0eee53663a0ab6c.zip
dev-python/apsw: add 3.39.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.39.4.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 29b5faaeabc1..d41a5c1ea3af 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -2,3 +2,4 @@ DIST apsw-3.38.5-r1.gh.tar.gz 338186 BLAKE2B 145e38d4057be498f85a655ad7a437ec19a
DIST apsw-3.39.2.0.gh.tar.gz 345634 BLAKE2B 433455fdb0dbc6192bbb3ef47cc1d54faa310715b81312b999a84f90de61e5362e4af8d3a705816100381ae920283d84a50fb2e51308227eecf9de5b7166c4ac SHA512 4d3eb68d47cf8114e7823969277d0f42c4091632d4aeab61f66e91e99601b6a5286875515e860e27a2f736c943dad1657f5c47cbdd23a3d1479d3019bfd1c05b
DIST apsw-3.39.2.1.gh.tar.gz 363389 BLAKE2B 001efa8904c724ec051ac18d80ce55ce646c12ea4a218536494fa0e5804781ccc6c66287575c21553c0a97f4a806a5c7ab671116667d0368c32f7e614fd32a2f SHA512 10f08320157be96ad409472b50480b1b1875ec88ccb00690851aaef5864aa2bfc8000fce10ef0f00b820cfd5cebad950f0e7bba432018524cb292a6738ff30e8
DIST apsw-3.39.3.0.gh.tar.gz 364874 BLAKE2B e23ca9ce125b2097f2e859d19053405070a3a09e061d27a175d4a3b721c4b68ac220b0522ca4e49075b937ebafdef8ba0cc5b0adc1ea389ee7c0c195b9f0850a SHA512 f9977f4112f2a7b11c0b0ab3576eada7b816dd69c518a637fc0152ba8fc4d12330febdd91abaf00af9e26049041024b590a4d60a9f055bf49c3301c92a68b539
+DIST apsw-3.39.4.0.gh.tar.gz 371139 BLAKE2B 223736e45b581f96cfcf4cd42f3aa278c0c3cc6b49188ac1979cc30835635f0f935eac8231d7ba0e1ae50f169095e672fe33c7938e6dbf94a7b82fc44d126002 SHA512 c09b367fa5825300c4a4fb82916077208ebd5741f9be4814d33032349eacdd6c7d528430e6d85615c56aaea30995c2575bfbe02876dc8e95e2c337a811df07e7
diff --git a/dev-python/apsw/apsw-3.39.4.0.ebuild b/dev-python/apsw/apsw-3.39.4.0.ebuild
new file mode 100644
index 000000000000..f10a20ff8b30
--- /dev/null
+++ b/dev-python/apsw/apsw-3.39.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}